Cut-Copy-Paste are NOW broken, Episode 6 - UX aspect of context menu isn't taken into account at all

RESOLVED DUPLICATE of bug 1271897

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 1271897
a year ago
11 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Cut, copy, paste buttons intentionally broken in bug 1159490 by Ehsan Akhgari)

(Reporter)

Description

a year ago
>>>   My Info:   Win7_64, Nightly 49, 32bit, ID 20160526082509
STR_1:
0. Move Cut-Copy-Paste toolbarbutton to toolbar
1. Open http://snag.gy
2. Press PrtSc key to make a screenshot
3. Right-click on the page, paste copied image to the page

AR:  It's not possible to use "paste" menuitem, because browser disabled it.
ER:  Either X or Y
 X) Everything should work just like before regression 1159490:  Step 2 - All items Should be disabled
 Y) Step 3 - all items should be enabled, i.e. Ehsan Akhgari should at least make his terrible design
    of Cut,Copy,Paste (that is illogical and doesn't make sense for people who use the browser) work
    as HE expects. I.e. should just finish the job. Or don't even start. I hope this concept is clear.

(In reply to Justin Dolske [:Dolske] from comment #7)
> I think Ehsan's point here is that disabling these Firefox menuitems would prevent using them on
> pages using the HTML clipboard API/events. EG, if the page is listening for the "copy" event to
> provide some page-specific data, the browser has to leave the menuitem enabled all the time.
Okay. But now you're blocking the new API by hiding menuitems completely.
(Reporter)

Updated

a year ago
Component: Untriaged → DOM: Events
Product: Firefox → Core
(Reporter)

Updated

a year ago
No longer blocks: 1277113

Comment 1

11 months ago
See bug 1271897 comment 5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271897
You need to log in before you can comment on or make changes to this bug.