Closed Bug 1303434 Opened 3 years ago Closed 3 years ago

Dashed box-shadow on Gmail text box

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox51 --- fixed

People

(Reporter: mccr8, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

If you delete a message in Gmail, you get a little yellow box containing the text "The conversation has been moved to the Trash.". This box has a shadow. I expect the shadow to be continuous across the text box, but on Nightly it has regular gaps, looking kind of like it is dashed. This dashing on the shadows is not present in Chrome.
What platform? I don't see this on OS X.
I could be reading this wrong, but it looks like the page is using box-shadow.

(In reply to Jeff Muizelaar [:jrmuizel] from comment #2)
> What platform? I don't see this on OS X.

I'm on OSX.
Summary: Discontinuous shadow on Gmail text box → Discontinuous box-shadow on Gmail text box
Version 10.11.6 to be specific. My computer has been having overheating issues, so maybe my GPU is failing in some very peculiar fashion that only affects box shadows in Firefox, and not in Chrome...
Also, I am on the 9-16 Nightly. I didn't notice this yesterday for what that is worth.
(In reply to David Baron :dbaron: ⌚️UTC+1 (busy September 14-25) from comment #6)
> Could https://hg.mozilla.org/mozilla-central/rev/b071166a07bc somehow be
> related?

Could well be. I updated my nightly and see the problem now too.
Flags: needinfo?(bas)
Duplicate of this bug: 1303334
Bug 1296665 sounds like a very good guess but it would be good to confirm it with a regression window search anyway.
Blocks: 1296665
Keywords: regression
FWIW, I can reproduce, using latest 64-bit Linux Nightly -- 51.0a1 (2016-09-16) (64-bit)
OS: Unspecified → All
Hardware: Unspecified → All
I'm seeing a similar rendering glitch when clicking Subscribe/Unsubscribe button on the right side of GitHub issues - see attached screencast.
In a local debug build of mozilla-central, reverting commit b071166a07bc (bug 1296665) fixes the dashed shadow for me on Gmail.
Summary: Discontinuous box-shadow on Gmail text box → Dashed box-shadow on Gmail text box
I think that means we can call this FIXED by backout (well, technically not until the backout is merged to central, but the sheriff won't know to resolve this bug at that point, so let's just do it now).

In the hopefully-unlikely event that this bug gets reintroduced when bug 1296665 relands, we can reopen at that point.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(bas)
Hi :Tomcat,
Is it also in 51 aurora?
Flags: needinfo?(cbook)
Looks like the backout is indeed on Aurora, from editing the URL:
  https://hg.mozilla.org/releases/mozilla-aurora/rev/4e8e39b7c8ed

(The backout actually merged to central on 2016-09-17 -- it just wasn't noted here until yesterday.  So, it was on central in plenty of time before the Aurora merge (which seems to have happened on 9/19).)
Flags: needinfo?(cbook)
You need to log in before you can comment on or make changes to this bug.