Closed Bug 1303526 Opened 3 years ago Closed 3 years ago

Crash in mozilla::a11y::DocAccessible::ProcessInvalidationList

Categories

(Core :: Disability Access APIs, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: marcia, Assigned: surkov)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-eff5ee78-6c28-429e-bb3d-413c62160917.
=============================================================

Seen while looking at Nightly crash stats. Started with 20160916030204 build: http://bit.ly/2d1Xf1b

Perhaps related to Bug 1302760? Adding ni on Michael Li.
Flags: needinfo?(michael.li11702)
Duplicate of this bug: 1303639
Crash Signature: [@ mozilla::a11y::DocAccessible::ProcessInvalidationList] → [@ mozilla::a11y::DocAccessible::ProcessInvalidationList] [@ nsDependentAtomString::nsDependentAtomString]
Michael is finished his internship. Alex is this fallout from bug 1296420?
Assignee: nobody → surkov.alexander
Flags: needinfo?(michael.li11702) → needinfo?(surkov.alexander)
Duplicate of this bug: 1304671
Currently the #1 browser crash on Nightly.
Attached patch patchSplinter Review
Flags: needinfo?(surkov.alexander)
Attachment #8794162 - Flags: review?(yzenevich)
Attachment #8794162 - Flags: review?(yzenevich) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/493087600f4b30666ae295f5a01a70db8b78d57e
Bug 1303526 - Crash in mozilla::a11y::DocAccessible::ProcessInvalidationList, r=yzen
https://hg.mozilla.org/mozilla-central/rev/493087600f4b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Hi :surkov, 
Since this bug also affects 51, do you consider to uplift this for 51 if this patch is not too risky?
Flags: needinfo?(surkov.alexander)
Comment on attachment 8794162 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1296420
[User impact if declined]: crashes
[Describe test coverage new/current, TreeHerder]:fair coverage on mochitest
[Risks and why]: low risk, null check
[String/UUID change made/needed]:no
Flags: needinfo?(surkov.alexander)
Attachment #8794162 - Flags: approval-mozilla-aurora?
Comment on attachment 8794162 [details] [diff] [review]
patch

Fix a crash. Take it in 51 aurora.
Attachment #8794162 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.