Intermittent devtools/client/responsive.html/test/browser/browser_menu_item_01.js | uncaught exception - TypeError: tab is undefined at _getSwitcher/switcher.onLayersReady@chrome://browser/content/tabbrowser.xml:3770:46

RESOLVED FIXED in Firefox 51

Status

defect
P1
normal
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: intermittent-bug-filer, Assigned: jryans)

Tracking

({intermittent-failure})

unspecified
Firefox 52
Dependency tree / graph
Bug Flags:
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox50 unaffected, firefox51 fixed, firefox52 fixed)

Details

(Whiteboard: [multiviewport][reserve-rdm])

Attachments

(3 attachments)

Priority: -- → P3
Whiteboard: [multiviewport][reserve-rdm]
I can reproduce issues like this locally in production use of the tool.  I'll take a look.
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Priority: P3 → P1
STR to trigger infinite loop:

1. Open tab 1 with some content
2. Open new RDM for tab 1
3. Open a new tab 2
4. Switch back to tab 1 where new RDM is open

Obviously tab switching is a critical case to handle well!
Iteration: --- → 52.2 - Oct 17
Flags: qe-verify-
Blocks: enable-rdm
Comment on attachment 8797818 [details]
Bug 1303595 - Support preserveLayers in RDM tunnel.

https://reviewboard.mozilla.org/r/83430/#review82188

Do you think we can somehow test that all the overloaded things are actually useful?
But I also feel bad from preventing landing something in the platform or firefox because some RDM hacks is no longer relevant...
Attachment #8797818 - Flags: review?(poirot.alex) → review+
Comment on attachment 8797819 [details]
Bug 1303595 - Update browser swap docs.

https://reviewboard.mozilla.org/r/83432/#review82190
Attachment #8797819 - Flags: review?(poirot.alex) → review+
Comment on attachment 8797820 [details]
Bug 1303595 - Add inner browser to browser -> tab map.

https://reviewboard.mozilla.org/r/83434/#review82194
Attachment #8797820 - Flags: review?(poirot.alex) → review+
(In reply to Alexandre Poirot [:ochameau] from comment #11)
> Comment on attachment 8797818 [details]
> Bug 1303595 - Support preserveLayers in RDM tunnel.
> 
> https://reviewboard.mozilla.org/r/83430/#review82188
> 
> Do you think we can somehow test that all the overloaded things are actually
> useful?
> But I also feel bad from preventing landing something in the platform or
> firefox because some RDM hacks is no longer relevant...

That's tricky...  I'll keep thinking about the right balance of testing here.  At the moment, I agree with you that I'd prefer to keep RDM out of the way of Firefox and Platform changes, even if that means this code needs to play catch up to adjust for those changes.
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/239ce795d3d8
Support preserveLayers in RDM tunnel. r=ochameau
https://hg.mozilla.org/integration/autoland/rev/592de616971b
Update browser swap docs. r=ochameau
https://hg.mozilla.org/integration/autoland/rev/93a6f8a97410
Add inner browser to browser -> tab map. r=ochameau
https://hg.mozilla.org/mozilla-central/rev/239ce795d3d8
https://hg.mozilla.org/mozilla-central/rev/592de616971b
https://hg.mozilla.org/mozilla-central/rev/93a6f8a97410
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Please request Aurora approval on this when you get a chance.
Flags: needinfo?(jryans)
Comment on attachment 8797818 [details]
Bug 1303595 - Support preserveLayers in RDM tunnel.

Approval Request Comment
[Feature/regressing bug #]: Updating new RDM to match browser changes from bug 1279086.
[User impact if declined]: If declined, new RDM will cause an infinite loop when switching tabs and pegs the CPU to 100%.  New RDM is disabled by default in Aurora, so the main impact there is to fix an intermittent test.
[Describe test coverage new/current, TreeHerder]: Landed on m-c, tested manually, fixes an automated test.
[Risks and why]: Low, feature is disabled by default in Aurora.
[String/UUID change made/needed]: None
Flags: needinfo?(jryans)
Attachment #8797818 - Flags: approval-mozilla-aurora?
Comment on attachment 8797819 [details]
Bug 1303595 - Update browser swap docs.

See comment 19.
Attachment #8797819 - Flags: approval-mozilla-aurora?
Comment on attachment 8797820 [details]
Bug 1303595 - Add inner browser to browser -> tab map.

See comment 19.
Attachment #8797820 - Flags: approval-mozilla-aurora?
Comment on attachment 8797818 [details]
Bug 1303595 - Support preserveLayers in RDM tunnel.

Now that the new RDM is disabled by default in Aurora, the risk should be low. We can take the fix in 51 aurora for the intermittent test error.
Attachment #8797818 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8797819 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8797820 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.