Certain animated image doesn't render quite right

RESOLVED DUPLICATE of bug 85595

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 85595
16 years ago
16 years ago

People

(Reporter: Kevin Brown, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Another URL of an image that doesn't render quite right:
http://forums.civfanatics.com/images/smilies/snipersmilie.gif

During part of the animation cycle, part of the image is cut off.

Comment 1

16 years ago
Confirming on Build ID: 2002032203 (0.9.9+) Windows 98.

Changing summary to reflect the specific case of this bug.

Old Summary: Certain animated images don't render quite right
New Summary: Certain animated image doesn't render quite right
Blocks: 119597
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Certain animated images don't render quite right → Certain animated image doesn't render quite right

Comment 2

16 years ago
I am seeing the same error in 2002041903 on MacOS X. Please change this bug from
PC/W2K to All/All.

I believe that something broke during the creation of RC1. I also have other
examples of animated gifs that are failing now. Attachments will follow.

Comment 3

16 years ago
Created attachment 80396 [details]
animated ad from Salon

Quite a few of the banner gifs at salon.com are displaying incorrectly in
recent builds. Here is the original image.

Comment 4

16 years ago
Created attachment 80398 [details]
screenshot of salon ad problem

The error seems to affect optimized gifs (i.e. only the changed rectangle is
updated in the new frame). I am also seeing gif errors on some slashdot banner
ads.

Black rectangles are displayed instead of the correct background image.

Comment 5

16 years ago
All/all
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

16 years ago
Attachment 80396 [details] looks fine on Build 20021903 for Win2k
I think the salon picture may be caused by Bug 137295 which is Mac specific.

Meanwhile, there's a patch in Bug 85595 that will fix the problem with
snipersmile.gif.
(Assignee)

Comment 7

16 years ago
marking as a dup of 85595

*** This bug has been marked as a duplicate of 85595 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
No longer blocks: 119597
You need to log in before you can comment on or make changes to this bug.