Filter UI: Action dropdown shows no (blank) Priority default selection

VERIFIED FIXED in mozilla1.2beta

Status

VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: laurel, Assigned: sspitzer)

Tracking

({regression})

Trunk
mozilla1.2beta
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
Using mar12 commercial trunk

When switching the filter ui action dropdown to Priority there is no default
selection and the dropdown appears blank.  Available choices are shown and
selectable when pulling the list down and Normal is checked as default, but was
not initially shown in the dropdown when switching action to priority.

Regression... seems to have broken last week, mar6 trunk selects Highest as
default and is shown in dropdown as default selection on switching to action
Change Priority.

Note:  Normal is checked as the default where previously we had Highest as the
default.  I didn't see this specified in filters spec, so which is our lasting
decision?

1.  From mail window, Edit|Message Filters|New.
2.  Switch action dropdown from MoveToFolder to Change Priority.  Note the value
dropdown shows a blank selection. Pull down the list and choices are shown and
selectable, Normal checked as the default.
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, regression
Summary: Filter UI: Action dropdown shows no (blank) Priority default selection → Filter UI: Action dropdown shows no (blank) Priority default selection

Comment 1

17 years ago
Discussed in Mail News bug meeting with Engineering, QA, Mktng and PjM. 
Decision was to minus this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2
taking, fix in hand.
Assignee: naving → sspitzer
Target Milestone: mozilla1.2alpha → mozilla1.2beta
Created attachment 99177 [details] [diff] [review]
fix

to make the default something else (like highest, normal seems like a weird
default) all we need to do is change const nsMsgPriorityValue Default = 4; in
MailNewsTypes2.idl
Created attachment 99182 [details] [diff] [review]
update.
Attachment #99177 - Attachment is obsolete: true
accepting.
Status: NEW → ASSIGNED
jglick, I think high or highest priority makes sense as a default.

why make the default normal, when most mail has normal priority?

(unless the common case is to create a filter to *normalize* priority, since 
it's set by sender, and not user)
fixed.

if you want to change from normal to something else, let me know.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

16 years ago
Using sep16 commercial trunk, we have a default selection, but the default is
"highest" on win98 and for linux and mac it's "normal".  Inconsistent -- what
was the final decision?

Comment 9

16 years ago
"highest" for all platforms.
(Reporter)

Comment 10

16 years ago
 bug 174437 has been logged to change the default selection, making all
platforms consistent at Highest.

Marking this one verified as indeed the default isn't blank anymore, ok using
oct14 commercial trunk.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.