Local build fails because path to mt.exe has spaces

RESOLVED DUPLICATE of bug 1293675

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 1293675
2 years ago
5 months ago

People

(Reporter: Jorg K (GMT+2), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Windows 7 64bit
Mozilla Build Tools 2.2.0
VS 2015 Update 3.

C:\mozilla-source\comm-central\obj-i686-pc-mingw32\config\autoconf.mk
receives
MT = c:/Program Files (x86)/Windows Kits/8.1/bin/x64/mt.exe

leading to this error:

60:47.28 msvc_raise_wrappers.cpp
60:47.33 C:/Users/jorgk/AppData/Local/Temp/make872-4.sh: line 4: syntax error near unexpected token `('
60:47.33 C:/Users/jorgk/AppData/Local/Temp/make872-4.sh: line 4: `              c:/Program Files (x86)/Windows Kits/8.1/bin/x64/mt.exe -NOLOGO -MANIFEST 'c:/mozilla-source/comm-central/mozilla/testing/tools/screenshot/screenshot.exe.manifest' screenshot.exe.manifest -OUTPUTRESOURCE:screenshot.exe\;1; \'
60:47.34 c:/mozilla-source/comm-central/mozilla/config/rules.mk:656: recipe for target 'screenshot.exe' failed
60:47.34 mozmake.EXE[4]: *** [screenshot.exe] Error 258
60:47.34 mozmake.EXE[4]: *** Deleting file 'screenshot.exe'

This is quite annoying since I cannot do any work ... and I lose one hour on every failed compile attempt.
(Reporter)

Comment 1

2 years ago
As a workaround, moved mt.exe elsewhere, so now I get in autoconf.mk
MT = c:/mozilla-build/7zip/mt.exe

Here goes the third hour of compilation.
(Reporter)

Comment 2

2 years ago
Maybe a regression form bug 1289246. I haven't compiled on this particular machine since June. I'n July/Aug and Sept. I've been using newly setup Win 10 machines, but today I returned to the Win 7 box just to find that I can't build on it any more.
Flags: needinfo?(mh+mozilla)
(Reporter)

Comment 3

2 years ago
Further to comment #1: Moving mt.exe to a folder without spaces in the name worked.

Updated

2 years ago
Component: Other → Build Config
Product: Release Engineering → Core
QA Contact: mshal
Did you disable 8.3 file names in some directories? See bug 1294475
Flags: needinfo?(mh+mozilla)
(Reporter)

Comment 5

2 years ago
Yes, since my development environment is on an SSD, I switched off 8.3 file names as a measure to reduce disk access. This is commonly done in SSD "optimisation tools".
That's the cause of this bug. The build system doesn't like spaces in various paths, MT being one of them. So for now, the build system relies on getting the short path (8.3) for them. For now, you need to enable 8.3 file names on the MSVC path.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293675

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.