Closed Bug 1304207 Opened 3 years ago Closed 3 years ago

[EME] Add telemetry tracking CDM usage

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: cpearce, Assigned: cpearce)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

I'd like some telemetry to track how often the Adobe and Widevine CDMs are used.
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

https://reviewboard.mozilla.org/r/79880/#review78640

r+ with typo fixed:

::: toolkit/components/telemetry/Histograms.json:8594
(Diff revision 1)
> +    "alert_emails": ["cpearce@mozilla.com"],
> +    "expires_in_version": "58",
> +    "bug_numbers": [1304207],
> +    "kind": "enumerated",
> +    "n_values": 6,
> +    "description": "MediaKeys CDM instanitated. 0=ClearKey, 1=Primetime, 2=Widevine, 3=unknown",

Typo: 'instanitated' -> 'instantiated'.
Attachment #8793100 - Flags: review?(gsquelart) → review+
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

https://reviewboard.mozilla.org/r/79880/#review78680

::: toolkit/components/telemetry/Histograms.json:8594
(Diff revision 1)
> +    "alert_emails": ["cpearce@mozilla.com"],
> +    "expires_in_version": "58",
> +    "bug_numbers": [1304207],
> +    "kind": "enumerated",
> +    "n_values": 6,
> +    "description": "MediaKeys CDM instanitated. 0=ClearKey, 1=Primetime, 2=Widevine, 3=unknown",

In addition to fixing the typo that Gerald pointed out, I would suggest improving the description in two other ways:

- mention "EME" in the description
- clarify when the data is collected

For example, would this be accurate?

    Note the type of CDM (0=ClearKey...) every time we instantiate an EME video.

or maybe there's some caching and it's more like:

    Note the type of CDM (0=ClearKey...) every time we need to instantiate one to play an EME video.
FYI, I need to double-check something with Benjamin before approving this. I'm going to leave the r? as a reminder.
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

(re-requesting review manually, as reviewboard isn't smart enough to parse r=gerald,r?=francois)
Attachment #8793100 - Flags: review?(francois)
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

https://reviewboard.mozilla.org/r/79880/#review78794

datareview+
Attachment #8793100 - Flags: review?(francois) → review+
Pushed by cpearce@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c9c2f19170d
Add telemetry to track when EME CDMs are instantiated. r=francois,gerald
https://hg.mozilla.org/mozilla-central/rev/2c9c2f19170d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

Approval Request Comment
[Feature/regressing bug #]: EME
[User impact if declined]: To help facilitate making a decision as to when we can remove Adobe EME from Firefox, we'd like to know how often the Adobe CDM is used for EME. This telemetry will help with that.
[Describe test coverage new/current, TreeHerder]: We have lots of EME tests.
[Risks and why]: Low; we're just adding telemetry.
[String/UUID change made/needed]: None.
Attachment #8793100 - Flags: approval-mozilla-beta?
Attachment #8793100 - Flags: approval-mozilla-aurora?
Comment on attachment 8793100 [details]
Bug 1304207 - Add telemetry to track when EME CDMs are instantiated.

New telemetry probe to understand EME CDM distribution, Aurora51+, Beta50+
Attachment #8793100 - Flags: approval-mozilla-beta?
Attachment #8793100 - Flags: approval-mozilla-beta+
Attachment #8793100 - Flags: approval-mozilla-aurora?
Attachment #8793100 - Flags: approval-mozilla-aurora+
Blocks: 1305552
Flags: needinfo?(cpearce)
Duplicate of this bug: EME_Telemetry
You need to log in before you can comment on or make changes to this bug.