Put the dll shim workaround from bug 1294650 back into 49

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: lizzard, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox49 verified, firefox50 fixed, firefox51 fixed, firefox52 fixed, firefox53 fixed, firefox54 affected)

Details

We put the shim into 48 and above, in bug 1294650. Then we backed it out from 49 and up in bug 1298157.   We know the shim fixed the crash on at least one older version of Websense for one users and Florin was able to see that result as well. But we don't know that the crashes on 49 for websense users (#2 top crash in the first day's crash-stats results) are the same, different, worse, or what version of websense they're caused by.  Without a ton of information to go on, we're going to put the shim back into place for windows users for 49.0.1.   We will also keep the 48.0.x users who we *know* have websense, on 48 for now. 

Sorry about doing the hokey pokey here. We don't have a good solution, but this may mitigate the frequency of the crash for websense users, so we are going to try it (again). 



+++ This bug was initially created as a clone of Bug #1298157 +++

[Tracking Requested - why for this release]:

This fix attempt didn't work, we can back it out.

https://hg.mozilla.org/mozilla-central/rev/d332de446548
https://hg.mozilla.org/releases/mozilla-aurora/rev/a72bfbdf5c9b
https://hg.mozilla.org/releases/mozilla-beta/rev/29dd7d227b7b
Wes or Ryan, can you land this on m-r please:  https://hg.mozilla.org/releases/mozilla-beta/rev/29dd7d227b7b
Flags: needinfo?(wkocher)
Flags: needinfo?(ryanvm)
https://hg.mozilla.org/releases/mozilla-release/rev/2d931a5eaf8a
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox49: --- → fixed
Flags: needinfo?(wkocher)
Resolution: --- → FIXED
Flags: needinfo?(ryanvm)
I've verified that the shim dll shows up after install and after update from various older versions (46.0.1-de, 47.0-it, 48.0-en-US, 48.0.1-fr, 48.0.2-ro, 49.0-es-ES) on Windows 7 x64 and Windows 8.1 x64.
Status: RESOLVED → VERIFIED
status-firefox49: fixed → verified
Hi Wes, we need this change in Fx50 RC2 as well. Could you please land this on m-r?
Flags: needinfo?(wkocher)
Because we are still affected by this stuff and we don't have . We should land it on every branch until we know it is fixed for real.
FYI, we shipped 50.1.0 with this shimm dll
https://hg.mozilla.org/releases/mozilla-release/file/aed42f9ce9f7/browser/installer/package-manifest.in#l144
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
status-firefox54: --- → affected
Hi Wes, Ryan, would you be able to land this on moz-release so we can spin a 51.0.1 build3? Thanks!
Flags: needinfo?(wkocher)
Flags: needinfo?(ryanvm)
https://hg.mozilla.org/releases/mozilla-release/rev/327e081221b064b05a302d7877c6e4be2949a617
status-firefox51: affected → fixed
Flags: needinfo?(wkocher)
Flags: needinfo?(ryanvm)
We should take it on all branches too to make sure we don't regress again.
You need to log in before you can comment on or make changes to this bug.