Selected tabs should not have a line between tab and contentframe

REOPENED
Unassigned

Status

()

Core
Widget: Win32
REOPENED
16 years ago
7 years ago

People

(Reporter: José Jeria, Unassigned)

Tracking

({polish})

Trunk
Future
x86
All
polish
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020312
BuildID:    20020312

See the page info with Windows XP and classic skin. The selected tab should not
be underlined as it is now. Se how the tabs are displayed in the display
properties of XP for example to see what i mean.
(Reporter)

Comment 1

16 years ago
Created attachment 73859 [details]
Pic showing selected tab with underline

Comment 2

16 years ago
-> Page Info
Component: XP Apps → Page Info

Comment 3

16 years ago
-->qa pmac@netscape.com
QA Contact: paw → pmac
Please reassign to the default owner if you change the component...
Assignee: trudelle → db48x
reassign to themes. probably a bug in the native theme support
Assignee: db48x → hewitt
Component: Page Info → Themes

Comment 6

16 years ago
->future
Target Milestone: --- → Future
(Reporter)

Comment 7

16 years ago
Also the Tabs in XP look weird. They dont look 100% selected due to this.

The buttons in the Page info also would need some left and right padding added
to them.
(Reporter)

Updated

16 years ago
Keywords: mozilla1.0

Comment 8

16 years ago
This is in fact a general problem in Classic skin. It occurs in other places
with tabs too (like address book cards). This does not happen in Modern. I'm
inclined to mark this INVALID as this is probably by design, however maybe
someone with more knowledge of UI design has an opinion on whether we should fix
this or not. CC'ing mpt. Also updating summary to better reflect real issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
Summary: Page Info with classic skin not correctly displayed in XP → [Classic] Selected tabs in classic skin should not have a line between tab and contentframe
(Reporter)

Comment 9

15 years ago
Any chance this could be fixed? Affecting tabs, page info etc
Looks really bad. 
Keywords: mozilla1.2
(Reporter)

Updated

15 years ago
Keywords: mozilla1.0, mozilla1.2 → mozilla1.3
(Reporter)

Updated

15 years ago
Keywords: mozilla1.3
happens on linux, though Mnyromyr says it doesn't happen on win2k
OS: Windows XP → All

Comment 11

12 years ago
Yes, Win2k and OSX are okay. 
But I see this in Linux, too, eg. using the SeaMonkey 1.0b GTK1 release.
(Reporter)

Updated

12 years ago
Summary: [Classic] Selected tabs in classic skin should not have a line between tab and contentframe → Selected tabs in classic skin should not have a line between tab and contentframe

Comment 12

12 years ago
WRT comment 2 - I see the underline with modern theme in SM w2k and XP Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060521 SeaMonkey/1.5a

About comment #12, I would say that MacOS X is not OK. It doesn't look as bad as in WinXP, but the basic problem remains: the selected tab is not connected to the tabpanel, as reported in bug #265698 which seems like a duplicate of this one to me.
(Reporter)

Updated

11 years ago
Assignee: hewitt → nobody
Component: Themes → XUL Widgets
Product: Core → Toolkit
QA Contact: pmac → xul.widgets
(Reporter)

Comment 14

11 years ago
Duping to newer bug that has a patch
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265698
(Reporter)

Comment 15

8 years ago
Reopening, since dupe was Linux only
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 16

8 years ago
Created attachment 427742 [details]
Same issue on Windows 7
(Reporter)

Updated

8 years ago
Summary: Selected tabs in classic skin should not have a line between tab and contentframe → Selected tabs should not have a line between tab and contentframe
(Reporter)

Comment 17

8 years ago
Requesting block, this make tabs look unpolished.
blocking2.0: --- → ?
This is a visual bug; we'd take a fix, but we'd release with it.
blocking2.0: ? → -
Component: XUL Widgets → Widget: Win32
Product: Toolkit → Core
QA Contact: xul.widgets → win32

Comment 19

7 years ago
Created attachment 534789 [details]
blow up

Comment 20

7 years ago
(In reply to comment #19)
> Created attachment 534789 [details]
> blow up

Note the gap in the border on the tab is bug 122248.
You need to log in before you can comment on or make changes to this bug.