Non-responsive Javascript causes whole browser to freeze

RESOLVED DUPLICATE of bug 516752

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 516752
a year ago
a year ago

People

(Reporter: krichter722, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Steps to reproduce:

Opened https://wiki.horde.org/CalDAV which causes the whole browser to freeze until the non-responsive Javascript dialog `Skript: https://wiki.horde.org/horde/static/d44ba53c7784cf71.js:2` appears.


Actual results:

The browser GUI was blocked for minutes.


Expected results:

There's no need to block more than one tab/GUI component which uses the script. Please use [threads](https://en.wikipedia.org/wiki/Thread_(computing)) for asynchronous computation tasks in order to avoid unnecessary blocks of the GUI.
The issue that blocking GUI should be solved by e10s.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 516752
You need to log in before you can comment on or make changes to this bug.