Firefox's system-notification-tray "Pause" button does not work, at NPR Politics Podcast page

REOPENED
Unassigned

Status

Tech Evangelism
Mobile
REOPENED
a year ago
a year ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [js] [needsdiagnosis], URL)

(Reporter)

Description

a year ago
STR:
 1. In Firefox Nightly on Android, visit http://www.npr.org/podcasts/510310/npr-politics-podcast
 2. Scroll down and click the "> Listen" button for one of the episodes.
 3. (After the media starts playing): Drag down your Android system notification tray, and click Firefox's "Pause" button that should have appeared there.

EXPECTED RESULTS:
Audio should be paused.

ACTUAL RESULTS:
The audio pauses for a fraction of a second, and then just keeps on playing.
Alastor, do you have time to investigate?
Blocks: 1290836
Flags: needinfo?(alwu)
Sure, I'll start to work on the media control next week, because this week I'm in the New Zealand for other working topic.
Assignee: nobody → alwu
Flags: needinfo?(alwu)
It's website JS issue, the website would resume its media immediately after user pressed the pause icon from media control.

I also tried to reproduce this issue on Android Chrome, and Chrome can't control this website as well. Chrome's media control interface would keep as playing state even you press the pause icon (we would also do that after solving the bug1302453)

There is nothing we can do, so close this bug.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

a year ago
(In reply to Alastor Wu [:alwu] from comment #3)
> It's website JS issue

OK -- but, WONTFIX isn't the correct resolution in this scenario. (WONTFIX means "it's a legitimate bug in our code, but we've decided to never fix it.")  This is a resolution which should only be used in rare circumstances. See https://bugzilla.mozilla.org/page.cgi?id=fields.html#status for more details on resolutions -- INVALID might have been what you were looking for (in that the described behavior is not a bug in Firefox code).

But in this case, since we're still left with a sadly broken user experience (and we believe the site's JS is what's causing the problem), the most productive resolution is probably to convert this into a Tech Evangelism bug, and hopefully someone can reach out to the site & get them to modify their JS so it interacts better with Firefox & Chrome's system-tray media integration. --> Reclassifying & reopening.
Status: RESOLVED → REOPENED
Component: Audio/Video → Mobile
Product: Firefox for Android → Tech Evangelism
Resolution: WONTFIX → ---
Since this bug was reopened and moved to "Tech Evangelism", so it should not block the bug1290836 anymore.
No longer blocks: 1290836
Comment #3 gives the start of an explanation. 
But this is not sufficient in the context of Tech Evangelism to do outreach. We need to dig into the code and pinpoint the reason, the piece of code and how to fix it.

Once done, we can switch to needscontact or contactready if the contact has been found.
Whiteboard: [js] [needsdiagnosis]
Hey Alastor, when pressing the pause/play icon from the system tray/media control, what is the expected behavior? Does the relevant tab receive a DOM media event?
Flags: needinfo?(alwu)
(In reply to Mike Taylor [:miketaylr] from comment #7)
> Hey Alastor, when pressing the pause/play icon from the system tray/media
> control, what is the expected behavior? Does the relevant tab receive a DOM
> media event?

Yes, it's the same as calling video.play() or video.pause().
Flags: needinfo?(alwu)
Free this bug because of the reason in comment3, this is a website's problem.
Assignee: alwu → nobody
They're using jPlayer v2.9.0 to control audio playback, which looks like the latest version. I tested and the jPlayer audio demo works as expected via media controls: http://jplayer.org/latest/demo-01/

So, something that the site is doing.
You need to log in before you can comment on or make changes to this bug.