comm-central-l10n build for linux is failed around ccache

RESOLVED FIXED in Thunderbird 52.0

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: t.matsuu, Assigned: aleth)

Tracking

unspecified
Thunderbird 52.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
According to the latest comm-central-l10n build log on linux, configure process is failed by the treatment of "--with-ccache".

mozbuild.configure.options.InvalidOptionError: Unknown option: --with-ccache

comm-central-l10n build log on linux:
https://archive.mozilla.org/pub/thunderbird/nightly/2016/09/2016-09-28-03-02-22-comm-central-l10n/comm-central-linux-l10n-nightly-ja-bm72-build1-build1588.txt.gz
(Reporter)

Updated

2 years ago
Blocks: 1267523
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1307380
(Reporter)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

2 years ago
Component: General Automation → Build Config
Product: Release Engineering → MailNews Core
QA Contact: catlee
See Also: → bug 1307380
(Assignee)

Comment 2

2 years ago
Linux 32b only
(Assignee)

Comment 3

2 years ago
Created attachment 8799150 [details] [diff] [review]
Avoid with-ccache l10n repack failure on 32b Linux

This just makes the 32b mozconfig consistent with the 64b one, which does not include mozconfig.cache.
Attachment #8799150 - Flags: review?(philipp)
(Assignee)

Updated

2 years ago
Assignee: nobody → aleth
Status: REOPENED → ASSIGNED
Comment on attachment 8799150 [details] [diff] [review]
Avoid with-ccache l10n repack failure on 32b Linux

Review of attachment 8799150 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp. if the reason this happens is really due to --disable-compile-environment, I think we should file a core bug to make the error message more clear, that the options are in conflict.
Attachment #8799150 - Flags: review?(philipp) → review+
(Assignee)

Comment 5

2 years ago
https://hg.mozilla.org/comm-central/rev/3d254838424f64f2f948e42f2c1070f72340e1df
Bug 1306193 - Avoid with-ccache l10n repack failure on 32b Linux. r=Fallen
(Assignee)

Comment 6

2 years ago
As this patch was untested, leaving this open until the next nightly to verify it resolves the issue.
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 52.0
(Assignee)

Comment 7

2 years ago
It worked. Followup core bug filed as Bug 1308774.
(Assignee)

Comment 8

2 years ago
Comment on attachment 8799150 [details] [diff] [review]
Avoid with-ccache l10n repack failure on 32b Linux

[Approval Request Comment]
User impact if declined: l10n repack failure
Testing completed (on c-c, etc.): yes
Attachment #8799150 - Flags: approval-comm-aurora?
(Assignee)

Comment 9

2 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/04ac4277680857a64fc1b85bc86cf133a7ca8335
Bug 1306193 - Avoid with-ccache l10n repack failure on 32b Linux. r=Fallen a=aleth

Updated

2 years ago
Attachment #8799150 - Flags: approval-comm-aurora? → approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.