mozbuild.configure.options.InvalidOptionError: Unknown option: --with-ccache

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

SeaMonkey 2.46 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
Linux l10n repack:

checking for target system type... i686-pc-linux-gnu
Traceback (most recent call last):
  File "/builds/slave/rel-c-rel-lnx-rpk/build/comm-release/configure.py", line 32, in <module>
    sys.exit(main(sys.argv))
  File "/builds/slave/rel-c-rel-lnx-rpk/build/comm-release/configure.py", line 24, in main
    sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
  File "/builds/slave/rel-c-rel-lnx-rpk/build/comm-release/mozilla/python/mozbuild/mozbuild/configure/__init__.py", line 256, in run
    raise InvalidOptionError('Unknown option: %s' % without_value)
mozbuild.configure.options.InvalidOptionError: Unknown option: --with-ccache
*** Fix above errors and then restart with\
               "make -f client.mk build"
make: *** [configure] Error 1
DEBUG: shell: unmounting all filesystems

this means that the --with-ccache *is* not necessary when
the disable-compile-environment.
Assignee

Comment 1

3 years ago
Attachment #8797542 - Flags: review?(iann_bugzilla)
Attachment #8797542 - Flags: review?(bugspam.Callek)

Comment 2

3 years ago
Comment on attachment 8797542 [details] [diff] [review]
[mozconfigs] remove --with--ccache option

[Triage Comment]
r/a=me
Attachment #8797542 - Flags: review?(iann_bugzilla)
Attachment #8797542 - Flags: review+
Attachment #8797542 - Flags: approval-comm-release+
Attachment #8797542 - Flags: approval-comm-beta+
Attachment #8797542 - Flags: approval-comm-aurora+

Updated

3 years ago
Assignee: nobody → ewong
Status: NEW → ASSIGNED
OS: Unspecified → All
Hardware: Unspecified → All
Assignee

Comment 3

3 years ago
https://hg.mozilla.org/releases/comm-release/rev/bc47f8327098dbcc9e3410027b17123f059ef997
Bug 1307380 - Remove --with-ccache option for release l10n mozconfigs. r+a=IanN
Assignee

Comment 4

3 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/61f6dc7450ea35675287471976ebf8997cb81c03
Bug 1307380 - Remove --with-ccache option from release l10n mozconfigs. r+a=IanN
Assignee

Comment 5

3 years ago
https://hg.mozilla.org/releases/comm-beta/rev/fb0f93891f3ea68d682dce4069f2fe1534919dab
Bug 1307380 - Remove --with-ccache option from release l10n mozconfigs. r+a=IanN
Assignee

Comment 6

3 years ago
https://hg.mozilla.org/comm-central/rev/9f2f7dcca50ce45d220309129f1becbd59376829
Bug 1307380 - Remove --with-ccache option from release l10n mozconfigs. r+a=IanN
Assignee

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Duplicate of this bug: 1306193

Updated

3 years ago
See Also: → 1306193

Comment 8

3 years ago
For which Target Milestone has this one been fixed?
Assignee

Updated

9 months ago
Attachment #8797542 - Flags: review?(bugspam.Callek)
You need to log in before you can comment on or make changes to this bug.