Crash in java.lang.NullPointerException: Attempt to read from field ''org.mozilla.gecko.EventDispatcher org.mozilla.gecko.GeckoApp.eventDispatcher'' on a null object reference at org.mozilla.gecko.GeckoApp.getEventDispatcher(GeckoApp.java)

RESOLVED FIXED in Firefox 52

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jchen, Assigned: droeh)

Tracking

({crash, regression})

unspecified
Firefox 52
All
Android
crash, regression
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-51762322-75a0-429f-b46b-081c62160930.
=============================================================

Regression from bug 1294821. Looks like PushService is registering a listener without an active GeckoApp.
(Assignee)

Comment 1

2 years ago
Created attachment 8796750 [details] [diff] [review]
PushService EventDispatcher fix

I think it's a mistake to be using the activity-specific EventDispatcher here; it should be the singleton EventDispatcher.
Attachment #8796750 - Flags: review?(nchen)
(Reporter)

Updated

2 years ago
Attachment #8796750 - Flags: review?(nchen) → review+

Comment 2

2 years ago
Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d10b44e4e488
Make PushService use the singleton EventDispatcher. r=jchen

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d10b44e4e488
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1307323
You need to log in before you can comment on or make changes to this bug.