New MAC OSX 10.12, Apple Mouse will not move display pages up, down, sideways?

RESOLVED FIXED in seamonkey2.46

Status

SeaMonkey
General
P1
major
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: acfe, Unassigned)

Tracking

SeaMonkey 2.40 Branch
seamonkey2.46

SeaMonkey Tracking Flags

(seamonkey2.46+ fixed, seamonkey2.47 fixed)

Details

(Whiteboard: [relnote fixed in Gecko 49 / SeaMonkey 2.46][fixed by bug 1070710])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:43.0) Gecko/20100101 SeaMonkey/2.40
Build ID: 20160120191716

Steps to reproduce:

Holding Mouse button down to move a page away to see the desktop.


Actual results:

When clicking om the top Page bar with the Apple USB mouse, I can no longer move the pages around on the desk top, the will not move any direction.

The mouse works perfectly on Firefox, Chrome and Safari, but not Seamonkey.


Expected results:

The web page should be able to be moved around on the desk top, it will not move!
(Reporter)

Updated

2 years ago
Severity: normal → major
Priority: -- → P1

Comment 1

2 years ago
> The web page should be able to be moved around on the desk top, it will not move!
NI: Stefan.

Comment 2

a year ago
(In reply to Philip Chee from comment #1)
> > The web page should be able to be moved around on the desk top, it will not move!
> NI: Stefan.
Oops
Flags: needinfo?(stefanh)

Comment 3

a year ago
Yeah, this is bug 1284859 which was fixed by bug 1070710. Note bug 1284859, comment #11, it does looks like Apple made a work-around, but that only works for the Firefox bundle identifier.

This means that the SeaMonkey version that is built from Gecko 50 will have the fix. NI Philip, since I think this needs to be in the relnote.

acfe@comcast.net, can you try and see if the method described in bug 1284859, comment #13 works for you (I'm still on 10.11, so I can't check)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(stefanh)
Flags: needinfo?(philip.chee)
Flags: needinfo?(acfe)

Comment 4

a year ago
Oh, wait - looks like the patch in bug 1070710 was uplifted to mozilla 49. Unless I miss something, the next SeaMonkey release will then have the fix.

Updated

a year ago
status-seamonkey2.46: --- → fixed
status-seamonkey2.47: --- → fixed
tracking-seamonkey2.46: --- → +
Depends on: 1070710
Flags: needinfo?(philip.chee)
Whiteboard: [relnote fixed in Gecko 49 / SeaMonkey 2.46][fixed by bug 1070710]
Target Milestone: --- → seamonkey2.46

Comment 5

a year ago
Closing because 2.46 is out so should be fixed. Please re-open if this is not the case for SeaMonkey 2.46
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Updated

a year ago
Flags: needinfo?(acfe)
You need to log in before you can comment on or make changes to this bug.