[10.12] Unable to drag Windows

VERIFIED FIXED in Firefox 49

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: mstange)

Tracking

(Blocks: 1 bug)

49 Branch
mozilla50
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 affected, firefox49 fixed, firefox50 fixed)

Details

(Whiteboard: tpi:+)

Seen while running with both Firefox Dev Edition and the latest beta. I am running the Sierra Beta 2 Version on an older 2010 Mac Mini.

STR:
1. Place my mouse in the top of the window and attempt to drag the window
2. Nothing happens.

The same maneuver can be completed successfully in Safari on the same machine.
(Reporter)

Updated

2 years ago
Blocks: 1283571
(Assignee)

Comment 1

2 years ago
I cannot reproduce this. I'm also on Sierra Beta 2.
What I do see is that you sometimes need to pull a little harder in order to move a window because it might be snapping to another window's edge. This edge snapping is new in Sierra.
(Assignee)

Comment 2

2 years ago
I can reproduce this on Nightly (built with --disable-replace-malloc and --disable-rust to work around bug 1284677), but not on Firefox Release. I built the Nightly using the 10.11 SDK.
(In reply to Markus Stange [:mstange] from comment #1)
> I cannot reproduce this. I'm also on Sierra Beta 2.
> What I do see is that you sometimes need to pull a little harder in order to
> move a window because it might be snapping to another window's edge. This
> edge snapping is new in Sierra.

I am using a Contour Mouse attached to the Mac Mini, and I have tried pulling harder but to no avail. I can double click in that same area and the window resizes, but I cannot get the window to move at all.

I tested with Chrome as well and no issues moving the windows around there either.
Keywords: qawanted

Comment 4

2 years ago
I reproduced the issue on macOS Sierra version 10.12 Beta 2 (16A239j) running latest beta 48.0b6 and latest Aurora 49.0a2. Can't reproduce the issue on latest Nightly 50.0a1 because I have some trouble opening it (maybe a known issue).
(Assignee)

Comment 5

2 years ago
Haha, the drag region is upside down! Fun.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
(Assignee)

Comment 6

2 years ago
We wouldn't have this problem if we had landed bug 1070710. I'm going to update the patches there and try once more for review.
Depends on: 1070710
(Assignee)

Comment 7

2 years ago
The only thing I'm not sure about is why this doesn't affect Release. Are we using a different SDK to compile Release vs Beta?
Keywords: qawanted

Comment 8

2 years ago
There's a difference between aurora and beta:

Aurora has a MacOS deployment target version of 10.7:
https://dxr.mozilla.org/mozilla-aurora/source/build/moz.configure/toolchain.configure#75

Beta has 10.6:
https://dxr.mozilla.org/mozilla-beta/source/build/moz.configure/toolchain.configure#78
(Assignee)

Comment 9

2 years ago
That might be the reason, then. Thanks for finding that out.
Ugh :(

Comment 10

2 years ago
Actually, my comment doesn't answer the question why this doesn't affect release, but happens in beta.
Related to why there is a difference between Aurora and Beta, from Apple:

<rdar://27034611> Firefox overrides private methods, application window cannot drag

After updating to macOS 10.12, I can no longer move the Firefox window around the screen (i.e. by clicking on the top part of the window and holding down the click while moving the cursor).  This used to work in OS X 10.11.

Mozilla in Firefox is override private methods
ChildView _regionForOpaqueDescendants:forMove:,
ChildView _regionForOpaqueDescendants:forMove:forUnderTitlebar:

We’ve checkfixed them which will expire when they rev their version after 48 or change their bundle identifier.

CFSTR("org.mozilla.firefox"), 48))

Updated

2 years ago
Priority: -- → P1
Whiteboard: tpi:+

Updated

2 years ago
Duplicate of this bug: 1285796
I have found a way to drag windows on both Nightly and Aurora - apparently I wasn't familiar enough with the feature. Once I drag it off from where it snaps, I can drag it around. The difference is in 10.11 I can place my cursor anywhere in the top browser chrome - in Sierra I have to get the drag handle and then once it is active I can move the window.
(Assignee)

Comment 14

2 years ago
Fixed by bug 1070710.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Verified fixed on nightly using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0 ID:20160719030224 CSet: feaaf1af1065257b9178faca8b67eed9657b4a17. I can now move the window around when I place my cursor at the top of the window.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1288449
(Assignee)

Comment 17

2 years ago
Hmm, Firefox Beta has the bundle identifier org.mozilla.firefox and the version 48.0 - do we know why Apple's workaround isn't working on it? Or does "will expire when they rev their version after 48" mean that it already won't work with version 48?

Updated

2 years ago
Duplicate of this bug: 1288982
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1305987
(Assignee)

Updated

2 years ago
status-firefox49: affected → fixed

Comment 20

2 years ago
This issue continues in macOS Sierra for me. 
On first set up of Thunderbird with an email account, you can see that it starts getting a bit difficult to move the window by the title bar. 

macOS Sierra v.10.12.2 (16C67)
Thunderbird v. 45.6.0
Enigmail v 1.9.6.1

Then at some point while doing the general set up of Thunderbird it stops moving by the title bar. To move it anywhere on my display, I have to resize it in order to move it anywhere else on the display. 

*Recreating*
I've set up:
macOS Sierra v10.12.2 (16C68)
Thunderbird v.45.6.0
Enigmail 1.9.6.1
on Parallels with only os updates and no additional software. 
Issue still shows up. 

Expectation: As soon as I 'grab' the title bar, I should be able to move the window anywhere else on my display as you can with any other software. 

Last Note: On Parallels, I've noticed that if I grab the window close to the green-enlarge button on the top-left of the window, I will have an almost 99% chance of moving the window. But it has to be before the tab. This is okay whether the window is active or not. 
This is not the case for the center of the title bar or any tab open.

Comment 21

2 years ago
UPDATE: Seems to work if I have View / Toolbars / Status Bar on. Odd, but okay. At least its not permanently stuck for me. Will continue to test.

Updated

2 years ago
Duplicate of this bug: 1333121
You need to log in before you can comment on or make changes to this bug.