Closed Bug 1306873 Opened 3 years ago Closed 3 years ago

Firefox sending unannounced SSRCs in simulcast, may not be sending RID

Categories

(Core :: WebRTC: Networking, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- affected
firefox51 --- affected
firefox52 --- fixed

People

(Reporter: jesup, Assigned: jesup)

References

Details

Attachments

(2 files)

Bug 1288904 was too aggressive in adding RID support to the SDP header extensions --  added it to audio streams (not useful) as well as to video streams when simulcast/RID wasn't negotiated.

This patch was developed as part of the update to webrtc branch 49 import, and ported back to trunk, like the patch in bug 1288904.  Nico wrote the patch, and I reviewed it and resolved nits (plus checked jsep_session_unittests).

The other patch here it the extmap direction support patch from the 49 update, which was reviewed by bwc in Bug 1250356.
Also removes RID support from audio

MozReview-Commit-ID: 28pmbvm4kw4
Comment on attachment 8796857 [details] [diff] [review]
extmap direction support and cleanup

r=bwc
Attachment #8796857 - Flags: review+
Comment on attachment 8796858 [details] [diff] [review]
only offer RID for video, and only if simulcast is being negotiated

r=jesup; I resolved nits in the original patch from Nico - it was still added RID to audio streams, and didn't adjust the constants in jsep_session_unittest
Attachment #8796858 - Flags: review+
Rank: 13
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e71268c4cc73
extmap direction support and cleanup r=bwc
https://hg.mozilla.org/integration/mozilla-inbound/rev/1378de3d013b
only offer RID for video, and only if simulcast is being negotiated r=jesup
https://hg.mozilla.org/mozilla-central/rev/e71268c4cc73
https://hg.mozilla.org/mozilla-central/rev/1378de3d013b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Depends on: 1307155
The second commit here caused a new build warning (for the single-case switch statement) - I filed bug 1307155 for that.
Duplicate of this bug: 1306475
You need to log in before you can comment on or make changes to this bug.