Update WebRTC code to webrtc.org stable branch 49

RESOLVED FIXED in Firefox 53

Status

()

defect
P1
major
Rank:
10
RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: pkerr, Assigned: jesup, NeedInfo)

Tracking

(Depends on 1 bug, Blocks 7 bugs)

47 Branch
mozilla53
Points:
13
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
No description provided.
backlog: --- → webrtc/webaudio+
Rank: 10
Blocks: 1300665
Blocks: 1302245
Adds basic directionality support for extmaps, and also removes RID from the audio extmaps.  Uses SendOnly for both audio-level and RID; note that this means in firefox-firefox calls, RID will be rejected at the SDP level.  This does not fix that RID is enabled in non-simulcast calls.
Attachment #8795400 - Flags: review?(docfaraday)
Assignee: pkerr → rjesup
Comment on attachment 8795400 [details] [diff] [review]
extmap_direction_support_and_cleanup

Review of attachment 8795400 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/webrtc/signaling/src/sdp/SdpHelper.cpp
@@ +756,5 @@
> +
> +           ((i->direction == SdpDirectionAttribute::Direction::kSendrecv ||
> +             i->direction == SdpDirectionAttribute::Direction::kRecvonly) &&
> +            (j->direction == SdpDirectionAttribute::Direction::kSendrecv ||
> +             j->direction == SdpDirectionAttribute::Direction::kSendonly)))) {

You can probably simplify this a lot by using the flags that make up the direction enum:

https://dxr.mozilla.org/mozilla-central/source/media/webrtc/signaling/src/sdp/SdpAttribute.h#184
Attachment #8795400 - Flags: review?(docfaraday) → review+
Blocks: 1302793
nico: your try had compile issues, and also didn't disable the test.
Try this:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=42c72403157ec15202d91a07135e92bb78922b6a
Blocks: 1324833
Blocks: 1325447

Comment 4

3 years ago
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e10e9f0e5ca2
Webrtc updated to upstream branch 49; pull made 2016-02-22 by pkerr rs=jesup
https://hg.mozilla.org/integration/mozilla-inbound/rev/126348e718d0
rollup of changes for webrtc after applying webrtc.org v49 update r=pkerr,ng,pehrsons,etc

Updated

3 years ago
Depends on: 1326011
as a note, there is a slight increase in the number of constructors measured during compilation:
== Change summary for alert #4650 (as of December 28 2016 00:45 UTC) ==

Regressions:

  2%  compiler_metrics num_constructors linux32 opt       97 -> 99.33
  2%  compiler_metrics num_constructors linux32 pgo       97 -> 99.25
  2%  compiler_metrics num_constructors linux64 pgo       97 -> 99.25
  1%  compiler_metrics num_constructors linux32 debug     178 -> 180.17
  1%  compiler_metrics num_constructors linux64 debug     178 -> 180.17

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=4650

We don't require anything here, this is just an FYI.

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e10e9f0e5ca2
https://hg.mozilla.org/mozilla-central/rev/126348e718d0
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Blocks: 1326288
Depends on: 1326386
No longer blocks: 1326288
Depends on: 1326288
Target Milestone: mozilla47 → mozilla53
I'm thinking this could probably use some QA testing at some point during the 53 cycle as well.
Iteration: 47.3 - Mar 7 → ---
Flags: qe-verify?
Depends on: 1326463
Depends on: 1328142

Updated

3 years ago
Depends on: 1328169
Depends on: 1329542
Depends on: 1330091
Depends on: 1330318
Depends on: 1331158

Updated

2 years ago
Depends on: 1335329

Updated

2 years ago
Depends on: 1336073
Depends on: 1338000
Depends on: 1339244
Blocks: 1340372
See Also: → 1341285
Depends on: 1342727
Depends on: 1337777
Depends on: 1339246

Updated

2 years ago
See Also: → 1345652
(In reply to Ryan VanderMeulen [:RyanVM] from comment #7)
> I'm thinking this could probably use some QA testing at some point during
> the 53 cycle as well.

Jesup, is there anything manual QA can do here to help? We need to be aware of testing needs as soon as possible, especially since this is already in Beta 53.
Flags: needinfo?(rjesup)
Depends on: 1350912
Depends on: 1349581
Depends on: 1337810
Depends on: 1363563
Blocks: 1406434
No longer blocks: 1406434
Depends on: 1406434
Depends on: 1441585
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.