Flash Plugin is no longer available on Latest Nightly52.0a1 (using profile created by Latest Nightly52.0a1)

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: alice0775, Assigned: benjamin)

Tracking

({regression})

52 Branch
mozilla52
x86
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/42c95d88aaaa7c2eca1d278399421d437441ac4d
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 ID:20161004030204

Steps To Reproduce:
1. Install latest Flash Player Plugin 23.0.0.162
2. Start Latest Nightly52.0a1
3. Open about:addons > Plugins
  --- observe, no Flash Player Plugin
4. Open https://helpx.adobe.com/flash-player.html
5. Click on [Check Now] Button
  --- observe, Sorry, Flash Player is either not installed or not enabled.

Actual Results:
Flash Plugin is no longer available

Expected Results:
Flash Plugin should be available. And Flash Plugin should be working properly
(Reporter)

Comment 1

2 years ago
It always happens on new profile[1] on latest Nightly52.0a1.
It always happens on older Firefox with the profile[1] which is created by latest Nightly52.0a1.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c1dd8b9b9915ba53fc4e2cb34e091ab7a1b514ea&tochange=fea5300238497189b0823fe4a1a09154a384ebc7

Regressed by: fea530023849	Benjamin Smedberg — Bug 1269807 - Remove support for all NPAPI plugins except for Flash, behind a pref. Tests that use the testplugin for now set the pref to keep it working. This will be disabled for ESR 52, but enabled for release 52. In the next cycle, the pref will be removed and this will be hardcoded. r=jimm
Blocks: 1269807
Flags: needinfo?(benjamin)
Keywords: regression
(Reporter)

Updated

2 years ago
Summary: Flash Plugin is no longer available on Latest Nightly52.0a1 → Flash Plugin is no longer available on Latest Nightly52.0a1 (using profile created by Latest Nightly52.0a1)
(Assignee)

Comment 2

2 years ago
Well now I feel stupid. I was checking the plugin *description* against "Shockwave Flash" instead of the *name*. Fix imminently.

Also, I need to reset the pluginreg version so that we don't inherit bad settings.
Assignee: nobody → benjamin
Flags: needinfo?(benjamin)
Tracking 52+ for this Flash regression.
tracking-firefox52: ? → +
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Attachment #8797707 - Attachment description: Bug 1307501 part B - don't read old versions of pluginreg.dat. Long ago we took great pains to read this backwards-compat because plugin enabled/click-to-play state was recorded here. But that has been recorded in prefs since Firefox 22, so now we can saf → Bug 1307501 part B - don't read old versions of pluginreg.dat. Long ago we took great pains to read this backwards-compat because plugin enabled/click-to-play state was recorded here. But that has been recorded in prefs since Firefox 22, so now we can saf…
Attachment #8797706 - Flags: review?(kyle)
Attachment #8797707 - Flags: review?(kyle)
Comment on attachment 8797707 [details]
Bug 1307501 part B - don't read old versions of pluginreg.dat. Long ago we took great pains to read this backwards-compat because plugin enabled/click-to-play state was recorded here. But that has been recorded in prefs since Firefox 22, so now we can saf

https://reviewboard.mozilla.org/r/83354/#review81874
Attachment #8797707 - Flags: review?(kyle) → review+
Comment on attachment 8797706 [details]
Bug 1307501 - Flash plugin isn't enabled in nightly because this check was using the description instead of the name.  obvious

https://reviewboard.mozilla.org/r/83352/#review81876
Attachment #8797706 - Flags: review?(kyle) → review+

Comment 8

2 years ago
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/113aa49cbb98
Flash plugin isn't enabled in nightly because this check was using the description instead of the name. r=stupidly obvious
https://hg.mozilla.org/integration/mozilla-inbound/rev/58e4d007f2a5
part B - don't read old versions of pluginreg.dat. Long ago we took great pains to read this backwards-compat because plugin enabled/click-to-play state was recorded here. But that has been recorded in prefs since Firefox 22, so now we can safely just treat this as a disposable cache. r=qdot

Comment 9

2 years ago
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b05f555321b7
part B followup - remove no-longer-needed variable to solve -Werror=unused-variable build bustage on a CLOSED TREE
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
(Assignee)

Updated

2 years ago
Blocks: 1308023

Comment 11

2 years ago
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/70cbf2ee09eb
Flash plugin isn't enabled in nightly because this check was using the description instead of the name. r=stupidly obvious
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6752015a180
part B - don't read old versions of pluginreg.dat. Long ago we took great pains to read this backwards-compat because plugin enabled/click-to-play state was recorded here. But that has been recorded in prefs since Firefox 22, so now we can safely just treat this as a disposable cache. r=qdot

Comment 12

2 years ago
Please let the private users choose if the adobe flash player is right for us!
I hate it when all of you developers us never asked fom mozilla firefox team :(

Let us decide how we use firefox and the other ones!

Thank you :)

Comment 13

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/70cbf2ee09eb
https://hg.mozilla.org/mozilla-central/rev/c6752015a180
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
(Assignee)

Updated

2 years ago
Flags: needinfo?(benjamin)
Depends on: 1308803
Depends on: 1308677
(Reporter)

Updated

2 years ago
No longer depends on: 1308677
You need to log in before you can comment on or make changes to this bug.