Regression in D3D11DeviceContext crashes with 50.0b

RESOLVED FIXED

Status

()

Core
Graphics: Layers
P3
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

({crash})

50 Branch
crash
Points:
---

Firefox Tracking Flags

(firefox50+ fixed, firefox51- fixed, firefox52 fixed)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
We have a regression in 50.0b3 with a few different signatures:
https://crash-stats.mozilla.com/search/?signature=~UpdateSubresource&proto_signature=~UpdateImage&product=Firefox&version=50.0b&process_type=browser&_sort=-date&_facets=signature&_facets=user_comments&_facets=adapter_vendor_id&_facets=platform_pretty_version&_columns=date&_columns=signature#facet-signature

Some might be OOMs (bug 1282562 and bug 1282564).

There's a large chunk of the crashes which have 'mozilla::layers::ImageClientSingle::UpdateImage(mozilla::layers::ImageContainer*, unsigned int)' in the stack trace:
https://crash-stats.mozilla.com/search/?signature=~UpdateSubresource&proto_signature=~UpdateImage&product=Firefox&version=50.0b&process_type=browser&_sort=-date&_facets=signature&_facets=user_comments&_facets=adapter_vendor_id&_facets=platform_pretty_version&_columns=date&_columns=signature#facet-signature

They affect 49 as well, but looks like the volume is higher on 50.

Correlations for signatures containing 'UpdateSubresource':
(58.83% in signature vs 10.43% overall) reason="EXCEPTION_ACCESS_VIOLATION_WRITE"
(96.85% in signature vs 48.62% overall) "D3D11 Layers+" in app_notes="True"
(96.85% in signature vs 49.95% overall) "D3D11 Layers?" in app_notes="True"
(71.03% in signature vs 26.28% overall) "DXVA2D3D9?" in app_notes="True"
(71.82% in signature vs 35.73% overall) "D2D1.1+" in app_notes="True"
(71.82% in signature vs 35.74% overall) "DWrite+" in app_notes="True"
(71.82% in signature vs 35.74% overall) "DWrite?" in app_notes="True"
(28.73% in signature vs 57.99% overall) "D2D1.1-" in app_notes="True"
(29.96% in signature vs 01.32% overall) address="0x1"
(63.70% in signature vs 37.44% overall) os_arch="amd64"
(47.71% in signature vs 21.48% overall) "DXVA2D3D9+" in app_notes="True"
(40.63% in signature vs 15.85% overall) adapter_vendor_id="0x10de"
(04.48% in signature vs 27.71% overall) dom_ipc_enabled="1"
(40.63% in signature vs 20.03% overall) "EGL+" in app_notes="True"
(40.63% in signature vs 20.33% overall) "WebGL+" in app_notes="True"
(40.63% in signature vs 20.87% overall) "GL Context+" in app_notes="True"
(40.63% in signature vs 20.87% overall) "GL Context?" in app_notes="True"
(40.63% in signature vs 20.93% overall) "EGL?" in app_notes="True"
(40.63% in signature vs 21.33% overall) "WebGL?" in app_notes="True"
(24.45% in signature vs 05.27% overall) "DXVA2D3D9-" in app_notes="True"
(27.89% in signature vs 09.45% overall) address="0x0"
(05.31% in signature vs 23.47% overall) url=""
(21.84% in signature vs 04.15% overall) GFX_ERROR "DXVA2D3D9 video decoding is disabled due to a previous crash."="True"
(36.15% in signature vs 53.11% overall) os_arch="x86"
(29.41% in signature vs 14.35% overall) platform_pretty_version="Windows 10"

(21.84% in signature vs 04.09% overall) GFX_ERROR "DXVA2D3D9 video decoding is disabled due to a previous crash."="True" ∧ "DXVA2D3D9-" in app_notes="True"
(29.32% in signature vs 12.37% overall) platform_pretty_version="Windows 10" ∧ "D2D1.1+" in app_notes="True"

There might be different crashes hidden in these signatures. More investigation
is needed to see what buckets became more frequent between 49 and 50.

Updated

2 years ago
Summary: Regression in D3D11DeviceContext crashes with 50.0b3 → Regression in D3D11DeviceContext crashes with 50.0b
(Reporter)

Comment 1

2 years ago
The patch from bug 1291084 comment 60 might fix this bug.

Comment 2

2 years ago
beta 5 seems to have largely addressed the intel gpu-related bucket of this crash.
(Reporter)

Updated

2 years ago
Depends on: 1291084

Updated

2 years ago
Severity: normal → major
Keywords: crash
Priority: -- → P3
Whiteboard: [gfx-noted]
(Reporter)

Updated

2 years ago
See Also: → bug 1310600

Comment 3

2 years ago
[Tracking Requested - why for this release]: The crash rates on 50 seem acceptable at the moment. Let's try to do something in 51 for this crash signature.
status-firefox51: --- → affected
tracking-firefox50: ? → +
tracking-firefox51: --- → ?
(Reporter)

Comment 4

2 years ago
This was probably fixed by bug 1308418 too, as bug 1310600.

The signatures are still there, but they are not looking worse in 50 compared to 49.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Looks like this was fixed or mostly mitigated by the bugs marco mentions in comment 4.
status-firefox50: affected → fix-optional
status-firefox51: affected → fix-optional
tracking-firefox51: ? → -
status-firefox50: fix-optional → fixed
status-firefox51: fix-optional → fixed
status-firefox52: --- → fixed
You need to log in before you can comment on or make changes to this bug.