Remove Android's hack (bug 846670) in js::GetNativeStackBaseImpl if 64-bit Android (Android-L or later)

RESOLVED DUPLICATE of bug 1357874

Status

()

RESOLVED DUPLICATE of bug 1357874
2 years ago
2 years ago

People

(Reporter: m_kato, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Unspecified
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 wontfix)

Details

By bug 846670, we add a hack into js::GetNativeStackBaseImpl() for android.  But this hack is unnecessary on Android 64-bit (and Android-L or later) due to https://android.googlesource.com/platform/bionic/+/642182341018b282148280a7bdb771493e15bd7d

So if Android 64bit or minimal API level is 21 or later, we should remove this hack.
Blocks: 1334963
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357874
You need to log in before you can comment on or make changes to this bug.