Java Script and DHTML Bug

RESOLVED DUPLICATE of bug 133867

Status

()

Core
DOM: Core & HTML
P3
major
RESOLVED DUPLICATE of bug 133867
16 years ago
16 years ago

People

(Reporter: Gregor, Assigned: jst)

Tracking

({qawanted})

Trunk
x86
All
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The onmouseover effect does not function any longer in this Script:

function wechsel(i, Pic)
{
if (imagenames.length+mouseover_imagenames.length==geladen)
window.document.images[i].src=Pic.src;
}

This function has problems with Pic.src on the right, everything is correctly 
only the picture is not exchanged.
No error message in the Script Debuger.
This Script is in the left Frame of http://www.netkult.com/

--------------------------

Option selected are ignored and is empty in Mozilla version 0.9.9 please see 
the control panel on Fun Stuff on http://www.netkult.com/

The Script of this:

<form>
<select style="position:absolute;left:80;top:27;font-size:10px;font-
family:Arial;" name="Auswahl" size="1" onChange="first(this.selectedIndex)" 
onmouseover="parent.infobox('<center>Themenauswahl</center>')" class="formtext">

<script LANGUAGE=JavaScript>
<!--

for (feld in inhalt)
	{
if (feld==12)
	document.write('<option selected>'+inhalt[feld][0]+' ('+inhalt[feld][1]
+')</option>');
else
	document.write('<option>'+inhalt[feld][0]+' ('+inhalt[feld][1]+')
</option>');

	}

//-->
</script>

</select>
</form>

--------------------------

Topic change over the control panel in Fun Stuff Area on 
http://www.netkult.com/ are ignored in the new version, on Mozilla < 0,9,9 
functioned this all perfect . 

Here is an error caused:

URL of the this script:
www.netkult.com/netkult/standard/humor/steuerung.js

That is ignored in the script only in Mozilla 0.9.9:

if(folgendeinitialisierung)
parent.rechts.location='rechts.htm';

--------------------------

Please look at the errors exactly, the same page functioned correctly with the 
IE.

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.netkult.com/


In the earlier versions of the Mozilla and in the IE everything functions 
normally !

Comment 1

16 years ago
Dupe of bug 130289 ?

Reporter, is your comment on above bug enough or do you need to leave this bug
open for another issue ? In other word, should we leave both bugs open ?
(Reporter)

Comment 2

16 years ago
Please, do not forget that it together 3 bugs are.
Here those are described possibly better. You can close the old bug report.
Excuse my bad English.


 
To DOM0
Status: UNCONFIRMED → NEW
Ever confirmed: true
um... dom0 for real
Assignee: rogerl → jst
Component: JavaScript Engine → DOM Level 0
QA Contact: pschwartau → desale
*** Bug 130289 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Severity = LOW[No Crash, Functional failure, No cosmetic failure]
Visibility = HIGH [Real world website usage, Gets one point of 
compatibility with other browsers since it works on other browsers. gets one 
more point on compliance with adopted techonology, that is JS] 

Priority = Visibility * Severity

Priority = p3

adding word "qawanted" because I'm setting this priority on available data & if 
someone feels otherwise then please investigate this more & feel free to change 
this priority.
Keywords: qawanted
Priority: -- → P3

Comment 7

16 years ago
The problem for the first bug is this line:
imagean[a].src="images/"+mouseover_imagenames[a];
The resulting src is 
http://www.netkult.com/images/links_funstuff_over.jpg
instead of
http://www.netkult.com/netkult/standard/images/links_funstuff_over.jpg
Did we change the way we resolve URL's?

The second bug (the selectbox is empty in the top frame), seems to be that we
don't select the option which has the selected attribute by default anymore.
CC'ing jkeiser. Is that possible?

I'm not sure about the third problem, since I can't reproduce it. Gregor, what
are the exact steps to reproduce the third problem please?
(Reporter)

Comment 8

16 years ago
1. Visit www.netkult.com 
2. Select Fun Stuff 
3. Change several times Topic (Thema:) in the top Frame

The right Frame (Frame name="rechts") does not change. 

That should appear with the change in: 
http://www.netkult.com/netkult/standard/humor/rechts.htm

That is ignored in the script only in Mozilla 0.9.9:
if(folgendeinitialisierung)
parent.rechts.location='rechts.htm';

Comment 9

16 years ago
I have the same behavior in IE and Mozilla: when I change the select, the "Fun
Stuff" page appears. The only select options which give another page are
"audios", "videos fun", "videos tiere", "video sport".
All the other options just display the same "Fun Stuff" page.
In IE the same thing happens.
(Reporter)

Comment 10

16 years ago
You can see the Bugs on this picture:
http://www.netkult.com/mozilla-bugs.jpg
There is no select when I look at the netkult page; when I try to go to Fun
Stuff, it says there is an error loading the page.
(Reporter)

Comment 12

16 years ago
You can see the Bugs on this picture:
http://www.netkult.com/mozilla-bugs.jpg

To the comparison, on Mozilla 0.9.8 everything is correct. 
http://www.netkult.com/mozilla-ok.jpg

Bug 3 occurs only sometimes with the topic change in Fun Stuff and only in 
release Build of Mozilla 0.9.9!
In Build 2002031708 no more! 
(Reporter)

Comment 13

16 years ago
This is Bug 2 http://www.netkult.com/mozilla_bug.html
Created attachment 75787 [details]
Minimized Testcase

That's what I needed, thanks!  It turns out that <option selected> is not even
being *added* to the select with document.write(), while <option> is.  (Count
the number of "Test" options in the select.)

Investigating.
(Reporter)

Comment 15

16 years ago
To bug 1: I have the Script somewhat simplified, now function it well. 
Good.  Closing this out in favor of the one I filed because I couldn't find this
one. :) 

*** This bug has been marked as a duplicate of 133867 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.