Closed Bug 1308761 Opened 6 years ago Closed 6 years ago

Re-enable non-Flash plugins for ESR52

Categories

(Core Graveyard :: Plug-ins, defect, P1)

defect

Tracking

(firefox-esr45 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox-esr5252+ verified, firefox53 unaffected, firefox54 unaffected)

VERIFIED FIXED
Tracking Status
firefox-esr45 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox-esr52 52+ verified
firefox53 --- unaffected
firefox54 --- unaffected

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file)

In release 52 we've disabled all plugins except Flash. For ESR 52 we want to leave these other plugins on, so we need to flip this pref on the ESR-specific branch. I'm filing this separately so that it can have good tracking flags for that change.

plugin.load_flash_only needs to be false.
There is not an ESR52 tracking flag yet, so to keep this on relman radar I'm going to mark it for 52.
If you are going to turn off load_flash_only, we would need to backout the patch in bug 846566 as well. Could you do that at the same time?
I would suggest backing out 846566 until 53. I really don't want to compound risk for ESR52.
Marking this as blocking for 52 so it doesn't get missed.
Depends on: 1320667
Depends on: 1330998
Depends on: 846566
Gerry, when will we have status-firefox-esr52 and tracking-firefox-esr52 flag ? With that we can correct the tracking here and leave FF52 as it was.
Flags: needinfo?(gchang)
Moving tracking to new esr52 flags.
Can we have a patch made and nominated for the esr52 branch some time soon?
Benjamin, can you please post a patch to set the "plugin.load_flash_only" pref on ESR52 or suggest someone else we can ask?
Flags: needinfo?(benjamin)
This is a patch against beta, because I presume there isn't a separate ESR branch yet.

We've already done QA testing that this pref works, but I think we should do a release QA pass on candidate ESR builds to make sure:

1) Java and silverlight show up in the addons manager
2) The browser uses them when appropriate
3) The "some plugins may be missing" notice is not present in the addon manager. It *will* be present in about:plugins, but we've decided that's ok.
Assignee: nobody → benjamin
Flags: needinfo?(benjamin)
An ESR52 branch now exists. It is being kept in sync with Beta 52 commits, but is not running CI tests.

https://hg.mozilla.org/releases/mozilla-esr52/
Depends on: 1334535
Comment on attachment 8837677 [details]
Bug 1308761 - Re-enable non-Flash plugins for ESR52,

https://reviewboard.mozilla.org/r/112736/#review114640
Attachment #8837677 - Flags: review?(jmathies) → review+
What is supposed to happen next with this bug? Do we wait until RC to branch ESR from the mainline release?
Flags: needinfo?(jcristau)
The ESR52 branch is already alive. Go ahead and request approval.
Flags: needinfo?(jcristau)
Attachment #8837677 - Flags: approval-mozilla-esr52?
Comment on attachment 8837677 [details]
Bug 1308761 - Re-enable non-Flash plugins for ESR52,

thanks Benjamin.  re-enable non-flash plugins in the esr52 branch.
Attachment #8837677 - Flags: approval-mozilla-esr52? → approval-mozilla-esr52+
Andrei, once it landed and the build is over (    http://archive.mozilla.org/pub/firefox/tinderbox-builds/ )
could you verify this?
Thanks
Flags: qe-verify+
Flags: needinfo?(andrei.vaida)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified fixed on 52.0.0esr-build4 using: Windows 7 x64, Windows 10 x64, Ubuntu 16.04 x64 and macOS 10.12.3. Non-Flash plug-ins can be enabled on 52esr and they work as intended.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(andrei.vaida)
Merci beaucoup! Have a great week end!
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.