NPAPI plugins can still be enabled in Nightly 53

VERIFIED FIXED in Firefox 52

Status

()

defect
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: pauly, Assigned: benjamin)

Tracking

53 Branch
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52+ verified, firefox53+ verified)

Details

Attachments

(1 attachment)

[Affected versions]:
- 52, 53

[Affected platforms]:
- all

[Steps to reproduce]:
1. Open FX 50.1.0 release with a new profile
2. In about:config create "plugin.load_flash_only=FALSE"
3. Start latest nightly using the same profile
4. Open about:addons / plugins -> NPAPI plugins enabled
5. Set "plugin.load_flash_only=TRUE"

[Expected result]:
- NPAPI plugins disabled

[Actual result]:
- NPAPI plugins enabled

[Regression range]:
- not sure if this is a regression or not
This is not a regression. It's also basically expected behavior. This "pref" is not designed to be flipped by users; it's designed to only be flipped as part of the config.

The only time this might continue to be a real issue is if somebody is switching back and forth between ESR and release, and therefore has a stale pluginreg file.  I'm not sure that's worth fixing.
After setting the plugin.load_flash_only pref, you need to manually delete the %USERPROFILE%\AppData\Mozilla\Firefox\Profiles\YOUR-PROFILE-NAME-HERE\pluginreg.dat file because it is caching the old plugin list.

Can you please confirm that the following upgrade scenario works correctly? This simulates the upgrade that ESR 52 users will see.

1. Create new user profile using an old Aurora *51* build:
http://ftp.mozilla.org/pub/firefox/nightly/2016/11/2016-11-13-00-40-06-mozilla-aurora/
2. Confirm that about:addons and about:plugins show all your plugins.
3. Create the plugin.load_flash_only pref = FALSE.
4. Open Aurora 51's Help -> About box to force an update to the latest Aurora 52.
5. Restart Aurora to version 52.
6. Do about:addons and about:plugins still show all your plugins? If not, that is a bug!
Blocks: 1308761
Flags: needinfo?(paul.silaghi)
Priority: -- → P3
(In reply to Chris Peterson [:cpeterson] from comment #2)
> 6. Do about:addons and about:plugins still show all your plugins? If not,
> that is a bug!
All plugins are displayed after update. About:plugins also displays the "Missing something? Some plugins are no longer supported" notification.
Setting "plugin.load_flash_only=TRUE" shows all plugins + about:plugins "missing" notification + about:addons "missing" notification.
Flags: needinfo?(paul.silaghi) → needinfo?(cpeterson)
Thanks for checking, Paul. So I believe comment 0 is expected behavior and not a bug.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → INVALID
I'm going to reopen this as I figured out a simple way to fix this on restart, so people switching between release and ESR get the correct config.
Assignee: nobody → benjamin
Status: RESOLVED → REOPENED
Priority: P3 → P2
Resolution: INVALID → ---
Comment on attachment 8827568 [details]
Bug 1330998 - Invalidate pluginreg.dat based on whether the flash-only pref is flipped, so that if users switch between 52 and 52ESR it gets updated correctly.

https://reviewboard.mozilla.org/r/105206/#review106024
Attachment #8827568 - Flags: review?(kyle) → review+
Pushed by bsmedberg@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bbdef7fdc1c6
Invalidate pluginreg.dat based on whether the flash-only pref is flipped, so that if users switch between 52 and 52ESR it gets updated correctly. r=qdot
Tracking note: This will improve ESR52 experience.
Comment on attachment 8827568 [details]
Bug 1330998 - Invalidate pluginreg.dat based on whether the flash-only pref is flipped, so that if users switch between 52 and 52ESR it gets updated correctly.

Approval Request Comment
[Feature/Bug causing the regression]: 1269807 - feature to enable only Flash
[User impact if declined]: Users switching between ESR and non-ESR may not see the expected plugin configuration
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Not yet
[Needs manual test from QE? If yes, steps to reproduce]: STR in bug
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: I don't think so; it invalidates a cache. In the worst case bug, we'd load fresh at each startup which is not a big deal.
[String changes made/needed]:None
Attachment #8827568 - Flags: approval-mozilla-aurora?
Stefan or Paul, can one of you please test and verify?
Flags: needinfo?(stefan.georgiev)
Flags: needinfo?(paul.silaghi)
Awesome! Verified fixed latest 53 inbound build - https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-win32/1484723366/
Flags: needinfo?(stefan.georgiev)
Flags: needinfo?(paul.silaghi)
https://hg.mozilla.org/mozilla-central/rev/bbdef7fdc1c6
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Tracking 52/53+ to improve the ESR experience.
Shouldn't we remove "plugin.load_flash_only" and hard-code 't' in pluginreg.dat on 53? The fix is something other than what the bug summary says.
Flags: needinfo?(benjamin)
Removing the load_flash_only pref will be done in a separate followup patch once a couple of product questions/dependencies are done.
Flags: needinfo?(benjamin)
Comment on attachment 8827568 [details]
Bug 1330998 - Invalidate pluginreg.dat based on whether the flash-only pref is flipped, so that if users switch between 52 and 52ESR it gets updated correctly.

handle flash-only pref flipping, aurora52+
Attachment #8827568 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed FX 52b5, 53.0a2 (2017-02-10) Win 7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.