page loading test is failing in selenium

RESOLVED FIXED in mozilla55

Status

RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: automatedtester, Assigned: whimboo)

Tracking

Version 3
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
These tests are failing and look like they should work. Raising bug to keep track and for us to investigate.

https://github.com/SeleniumHQ/selenium/blob/master/py/test/selenium/webdriver/common/page_load_timeout_tests.py
I'm sure this is a dupe of bug 1307127. But lets mark it dependent for now.
Depends on: 1307127
(In reply to Henrik Skupin (:whimboo) from comment #1)
> I'm sure this is a dupe of bug 1307127. But lets mark it dependent for now.

Andreas, mind having a look if that is true or not?
Flags: needinfo?(ato)
FYI only testClickShouldTimeout in the Selenium suite is failing. The other test in the file testShouldTimeoutOnPageLoadTakingTooLong is passing. I've seen reports of this elsewhere - the initial page load is always fine, but a click that causes another page load will not wait for the page load to complete before returning.
Based on what davehunt is saying, it sounds like this is not a dupe/dependent on https://bugzilla.mozilla.org/show_bug.cgi?id=1307127.

It is true that we do not employ implicit wait checks on clicking.  However, it has still not been decided by the WebDriver WG whether we are meant to do that yet.
Flags: needinfo?(ato)
(Reporter)

Comment 5

a year ago
The waiting on clicks for page transitions has been landed so going to assume this has been fixed
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Yes, click and pageload has been implemented in bug 1335778. Since then Marionette can run into a timeout.

Sadly I cannot set the milestone to 54 because due to a bug it's not available under the testing component.
Assignee: nobody → hskupin
Depends on: 1335778
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.