Params aren't shown as expected in the HTTP inspector

RESOLVED FIXED in Firefox 52

Status

DevTools
Console
P1
normal
RESOLVED FIXED
2 years ago
a month ago

People

(Reporter: Lay András, Assigned: Honza)

Tracking

({testcase})

48 Branch
Firefox 52
testcase

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8799764 [details]
firefoxdeveloper.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

I submitted a form, containing this:

<input type="checkbox" name="box[]" value="123" checked>
<input type="checkbox" name="box[]" value="456" checked>




Actual results:

In the web console, under POST tab, the Params section only show this:

box[]  123


Expected results:

box[]  123
box[]  456

In the Raw Data section both of them shows:

box%5B%5D=123&box%5B%5D=456

Updated

2 years ago
Component: Untriaged → Developer Tools: Console

Comment 1

2 years ago
Could you attach a simple testcase to reproduce the issue, please.
Flags: needinfo?(andras)
Keywords: testcase-wanted
(Reporter)

Comment 2

2 years ago
Simple testcase: http://bogex.hu/test/webconsole.php

Comment 3

2 years ago
Created attachment 8800629 [details]
screen-ff52.jpg

I can't reproduce it with FF52 32b.

Updated

2 years ago
Keywords: testcase-wanted → testcase

Comment 4

2 years ago
Created attachment 8800664 [details]
console.jpg

He is not at the Network tab. He is at console, when POST happens, expand the data (not clicking on link, click on the arraw), and then POST tab.

There is only one param. This is a real bug.

I think you should disable or remove that from the FF because it could be confusing, let's force the users to use the Network tab.

Comment 5

2 years ago
Created attachment 8800671 [details]
ff52console.jpg

AFAIK, it has been removed with the new experimental console in Nightly.
So I'd say the bug will be "fixed" in next versions of Firefox.
The plan is a little complex.

There are multiple views of the console. There is the web console, which most web developers use, and then there is the browser console and browser toolbox: https://developer.mozilla.org/en-US/docs/Tools/Browser_Console

The browser console does not have a net monitor. We will likely add this back in for the browser console but not in the web console.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

Updated

2 years ago
Summary: Firefox developer edition web console issue → Params aren't shown as expected in the HTTP inspector

Comment 7

2 years ago
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=bccb11375f2af838cda714d42fd8cef78f5c7bf1&tochange=27104628616c5550fc56b060e727248c5f3a1c2c
Blocks: 1211525
Flags: needinfo?(andras) → needinfo?(odvarko)
Version: 51 Branch → 48 Branch
(Assignee)

Comment 8

2 years ago
Created attachment 8801697 [details] [diff] [review]
bug1309243.patch

Patch attached.

- Make React key prop unique
- Extend and existing test to cover the bug

Thanks for the report!

Honza
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Flags: needinfo?(odvarko)
Attachment #8801697 - Flags: review?(chevobbe.nicolas)
(Assignee)

Comment 9

2 years ago
(In reply to Lin Clark [:linclark] from comment #6)
> The plan is a little complex.
> 
> There are multiple views of the console. There is the web console, which
> most web developers use, and then there is the browser console and browser
> toolbox: https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
> 
> The browser console does not have a net monitor. We will likely add this
> back in for the browser console but not in the web console.
Lin, we are not putting the HTTP logs back into the web console? This was one of the most requested features in Firebug community and it was also one of the reasons why we had it in the Web Console. It would be great to have it back.

Honza
Flags: needinfo?(lclark)
Priority: P2 → P1
Patrick has already asked Bryan to decide this in Bug 1308219.

My personal feeling is that the current status (having two views on the same data) is confusing for users and that we should have a UX review before reimplementing everything as it is now. I leave the decision up to Bryan, though.
Flags: needinfo?(lclark)
Comment on attachment 8801697 [details] [diff] [review]
bug1309243.patch

Review of attachment 8801697 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me !
One minor thing on the test, but feel free to lands this as is.

::: devtools/client/webconsole/net/test/mochitest/browser_net_params.js
@@ +59,5 @@
> +  let tabBody = yield selectNetInfoTab(hud, netInfoBody, "params");
> +
> +  let params = tabBody.querySelectorAll(
> +    ".netInfoParamName > span[title='box[]']");
> +  is(params.length, 2, "Two URI parameters  must exist");

could we check the content of each param too ?  I don't really see how this could happen now, but it will prevent to be bitten by a refactor that would use the property name to retrieve the value for example.
No strong opinion on this, it would be an extra safety net
Attachment #8801697 - Flags: review?(chevobbe.nicolas) → review+
(Assignee)

Comment 12

2 years ago
Created attachment 8801760 [details] [diff] [review]
bug1309243.patch

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #11)
> could we check the content of each param too ?  I don't really see how this
> could happen now, but it will prevent to be bitten by a refactor that would
> use the property name to retrieve the value for example.
> No strong opinion on this, it would be an extra safety net
Sure, done.

Thanks for the review!

Honza
Attachment #8801697 - Attachment is obsolete: true
Attachment #8801760 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 13

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/be0b952903d0
Use unique key property; r=nchevobbe
Keywords: checkin-needed

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/be0b952903d0
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1316833

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.