Uplift NSS 3.21.3 to Firefox 45.x

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: kaie, Unassigned)

Tracking

3.21.1
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr4550+ fixed, firefox50 unaffected)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
This bug is for the decision, if NSS 3.21.3 should be uplifted to Firefox ESR 45.x, or if you'd like to skip.
Reporter

Updated

3 years ago
Reporter

Updated

3 years ago
Depends on: CVE-2016-5285
Reporter

Updated

3 years ago
Reporter

Comment 1

3 years ago
Please execute the two commands from the attached text file, for updating the ESR-45 branch to the NSS 3.21.3 release (which will bring the fixes from the bugs in the dependency list, only).

The update is optional for Firefox. It's up to Mozilla if you want to pick up these fixes now, or at a later time, as part of potential future NSS updates for ESR45.
Attachment #8801825 - Flags: approval-mozilla-esr45?
Comment on attachment 8801825 [details]
commands to uplift NSS 3.21.3 to the ESR45 branch

Approved, I landed it myself
Attachment #8801825 - Flags: approval-mozilla-esr45? → approval-mozilla-esr45+
(In reply to Sylvestre Ledru [:sylvestre] from comment #3)
> https://hg.mozilla.org/releases/mozilla-esr45/rev/
> 3f5b37f887a1daf40aa2985a806469dc9a1ead2e

FWIW, this landed with bug 1158489 in the commit message.
Group: crypto-core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.