Last Comment Bug 1310017 - Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter
: Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter
Status: RESOLVED FIXED
: addon-compat
Product: Core
Classification: Components
Component: Widget (show other bugs)
: unspecified
: All All
-- normal (vote)
: mozilla52
Assigned To: Eric Rahm [:erahm]
:
:
Mentors:
Depends on: 1311064
Blocks: nuke-nsSupportsArray
  Show dependency treegraph
 
Reported: 2016-10-13 14:19 PDT by Eric Rahm [:erahm]
Modified: 2016-10-18 11:26 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter (51.68 KB, patch)
2016-10-13 14:19 PDT, Eric Rahm [:erahm]
bugs: review+
Details | Diff | Splinter Review

Description User image Eric Rahm [:erahm] 2016-10-13 14:19:23 PDT
|nsISupportsArray| is deprecated. It should be pretty straightforward to swithc over to nsIArray in nsITransferable and nsIFormatConverter.
Comment 1 User image Eric Rahm [:erahm] 2016-10-13 14:19:25 PDT
Created attachment 8800859 [details] [diff] [review]
Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter

This converts |nsITransferable.flavorsTransferableCanExport| and |nsITransferable.flavorsTransferableCanImport| to return a |nsIArray|.

A search of the addons repo shows a few usages. It's used in multiple copies of "Google Toolbar for Firefox" which has not been supported by Google since 2011 [1]. The rest either just call the method but don't use the return value or are in dead code paths. A full list with notes is below [2]. A cursory search of c-c shows no hits.

|nsIFormatConverter.getInputDataFlavors| and |nsIFormatConverter.getOutputDataFlavors| are updated as well. A search of the addons repo shows no usage of either function. A cursory search of c-c shows no hits.

Olli, I chose you to review as you have previous context for what I'm doing here but feel free to redirect.

[1] https://www.google.com/intl/en/toolbar/ff/index.html
[2] Addon references:

> 478082-install.rdf - OccupyID-1 - by Mike Perry
>   - dead code, only path is from a message observer for a non-existent message
> 663818-install.rdf - Auto Copy for DTS - by XdemonicX
>   - referenced, but not used
> 674311-install.rdf - easyDITA Copy Paste Plugin - by Jorsek, LLC
>   - referenced, but not used
> 699601-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 710868-install.rdf - ggl Toolbar for Firefox - by ggl
> 720372-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 720375-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 720467-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 720715-install.rdf - My Own Google Toolbar for Firefox - by me
> 721684-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 725138-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 726215-install.rdf - Auto Copy - by Michael Lidman
>   - referenced, but not used
> 727695-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 728065-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 728068-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 730407-install.rdf - Google Toolbar for Firefox - by Google Inc.
> 737130-install.rdf - Google Toolbar for Firefox - by Google Inc.
Comment 2 User image Olli Pettay [:smaug] (pto-ish for couple of days) 2016-10-13 15:49:19 PDT
Comment on attachment 8800859 [details] [diff] [review]
Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter

So code is fine, but please ask feedback from someone dealing with addons.
Comment 3 User image Eric Rahm [:erahm] 2016-10-13 17:17:06 PDT
Jorge, does this seem okay from an addons perspective? See detailed breakdown in comment 1.
Comment 4 User image Jorge Villalobos [:jorgev] 2016-10-14 13:59:54 PDT
Sounds good. No objections here.
Comment 7 User image Eric Rahm [:erahm] 2016-10-16 12:44:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/bd7461a1ed09447f4d38b4911f0e83933f9d875b
Bug 1310017 - Remove nsISupportsArray usage from nsITransferable and nsIFormatConverter. r=smaug
Comment 8 User image Carsten Book [:Tomcat] 2016-10-17 02:36:04 PDT
https://hg.mozilla.org/mozilla-central/rev/bd7461a1ed09

Note You need to log in before you can comment on or make changes to this bug.