Closed Bug 1310189 Opened 4 years ago Closed 4 years ago

Crash in nsCOMArray_base::ReplaceObjectAt

Categories

(Core :: XPCOM, defect)

52 Branch
All
Windows
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed

People

(Reporter: simona.marcu, Unassigned)

References

Details

(5 keywords)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-58717263-5617-404c-b362-13b952161014.
=============================================================
After updating to the latest Nightly (Build ID :20161014030204), it crashes every time you write something in the address bar.

Steps to reproduce:
1. Launch the latest Nightly
2. Focus the address bar
3. Start typing an URL

Expected results:
Navigating should be allowed.

Actual results:
Firefox crashes the second you type anything in address bar.

Regression range: I'm currently searching for a regression window and I'll post the results ASAP.
  
Note:
Only the x86 builds are crashing on Windows 10 x64 bit. The 86_x64 builds are not crashing.
retriggered nightly builds for this fix btw
The mozregression tool took me to this regression window:

Last good revision: 5af415bbb1072acb039b7a76779ac91d98762890
First bad revision: 96d1b7238832ebf3e7e03053db19a8e557f6ca42
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5af415bbb1072acb039b7a76779ac91d98762890&tochange=96d1b7238832ebf3e7e03053db19a8e557f6ca42

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1308317
Startup crash after update to 52.0a1 (2016-10-14) (64-bit) on Windows 7 (64-bit).
Blocks: 1308317
Severity: critical → blocker
Flags: needinfo?(erahm)
Keywords: crashreportid
OS: Windows 10 → Windows
Hardware: x86 → All
Version: Trunk → 52 Branch
(In reply to Simona B [:simonab ] from comment #3)
> The mozregression tool took me to this regression window:
> 
> Last good revision: 5af415bbb1072acb039b7a76779ac91d98762890
> First bad revision: 96d1b7238832ebf3e7e03053db19a8e557f6ca42
> Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/
> pushloghtml?fromchange=5af415bbb1072acb039b7a76779ac91d98762890&tochange=96d1
> b7238832ebf3e7e03053db19a8e557f6ca42
> 

yeah should be fixed by https://hg.mozilla.org/mozilla-central/rev/0c899672fff6ae00f5b3affbec48ee4daac35fa1 in the new nightly in about 90 minutes
> Looks like the following bug has the changes which introduced the regression:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1308317
Duplicate of this bug: 1310225
Duplicate of this bug: 1310251
Somebody fix it now .9:00 PM in Poland after update.Please don't do it.If you update please see people work on this Browser everyday.
Nightly build is pre-alpha build dedicated for testers.
If you can't handle it, just use stable or ESR build for everyday usage like other people.
The signature [@ ns_if_addref<T> ] seems like another regression from this bug, or another variant. I'll just put it in here for now.
Examples:
  bp-e8ed76aa-c741-4b56-940b-a7d0c2161014
  bp-c5c04ece-cded-405e-97e0-118372161014
Crash Signature: [@ nsCOMArray_base::ReplaceObjectAt] → [@ nsCOMArray_base::ReplaceObjectAt] [@ ns_if_addref<T> ]
Keywords: topcrash
Confirm fixed in build 20161014060324, thanks!
Crash Signature: [@ nsCOMArray_base::ReplaceObjectAt] [@ ns_if_addref<T> ] → [@ nsCOMArray_base::ReplaceObjectAt] [@ nsCOMArray_base::InsertObjectsAt] [@ ns_if_addref<T>]
This has been fixed by backing out bug 1308317, the new Nightly works properly.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(erahm)
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
This seems to be still crashing for me

https://crash-stats.mozilla.com/report/index/32b26b0b-dce3-47d6-be71-e31622161015#tab-rawdump

Keeps telling me im up to date.
latest build is 20161014060324 yours is 20161014030204
¡Hola!

I had https://crash-stats.mozilla.com/report/index/debb0e5f-81d4-4847-8c44-cf8a42161017 but not anymore so verifying FWIW.

¡Gracias!
Alex
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.