Balrog should refuse to make direct changes to objects that require Signoff

RESOLVED DUPLICATE of bug 1310210

Status

Release Engineering
Balrog: Backend
RESOLVED DUPLICATE of bug 1310210
a year ago
11 months ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

a year ago
When Required Signoffs are implemented, Balrog should absolutely not make direct changes to objects that require Signoff. This should be enforced at a low level (probably AUSTable).

One thing that we may want to consider is converting direct updates like this into a Scheduled Change rather than rejecting them outright. This may be more convenient for the user, and possibly simplify some of the other implementation. OTOH, this might just be confusing.
(Assignee)

Updated

a year ago
Depends on: 1310210
(Assignee)

Updated

a year ago
Blocks: 1278974
(Assignee)

Comment 1

11 months ago
This ended up making sense to do as part of bug 1310210.
Assignee: nobody → bhearsum
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1310210
You need to log in before you can comment on or make changes to this bug.