Closed Bug 1310678 (webvr_2.0) Opened 4 years ago Closed 2 years ago

[webvr] [meta] WebVR 2.0 API

Categories

(Core :: WebVR, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1419190

People

(Reporter: kip, Assigned: kip)

References

(Depends on 1 open bug, )

Details

(Whiteboard: [webvr])

The WebVR 1.2 API update is driven by support for WebVR in WebWorkers

The scope and interface changes are still under discussion.  I'll add bugs here as work items are identified.
Depends on: 1310682
Depends on: 1306436
Depends on: 1306434
Whiteboard: [webr]
Whiteboard: [webr] → [webvr]
Alias: webvr_1.2
In the last WebVR implementers meeting, the naming of the WebVR 1.2 spec was discussed.  The conclusion was to make it a major version number change to reflect the decision to include changes that break WebVR 1.1 compatibility.

Any dependencies under this meta-bug should be implemented with the consideration that the WebVR 2.0 spec (formally 1.2) is still under heavy churn.
Alias: webvr_1.2 → webvr_2.0
Summary: [webvr] [meta] WebVR 1.2 API → [webvr] [meta] WebVR 2.0 API
Component: Graphics → WebVR
Depends on: 1291777
The WebXR spec has replaced the earlier WebVR 2.0 proposals.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1419190
You need to log in before you can comment on or make changes to this bug.