Make h2 tests break next time our node setup gets broken

RESOLVED FIXED in Firefox 53

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: u408661, Assigned: u408661)

Tracking

51 Branch
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox53 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(1 attachment)

Part of bug 1248198 made our h2 tests silently fail (by being skipped) since infra doesn't have a modern-enough node installed. We need to fix the condition such that the tests will fail if our node setup on infra doesn't work right.

Of course, since the tests would be broken if run right now (since we no longer have NPN, and our old node doesn't support ALPN), this needs to wait for a node upgrade to occur on infra.
Whiteboard: [necko-active]
In testing my WIP patch for this bug, it looks like something h2-related may have already broken since the tests ended up silently disabled: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b66f2859f3a2 (webpush stuff - base h2 tests still pass just fine).

I've emailed the webpush people so they can take a look at the failures there.
(In reply to Nicholas Hurley [:nwgh][:hurley] from comment #1)
> In testing my WIP patch for this bug, it looks like something h2-related may
> have already broken since the tests ended up silently disabled:
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=b66f2859f3a2
> (webpush stuff - base h2 tests still pass just fine).
> 
> I've emailed the webpush people so they can take a look at the failures
> there.

It's just because buildbot node is too old to support ALPN (hence h2). That is, bug 1283871.
OK, so here we have a try run for the patch (that I'm about to r? on) showing try continuing to be green: https://treeherder.mozilla.org/#/jobs?repo=try&revision=8244da96dbf2

And here we have a try run on top of that forcing the node server to not be running (in the same fashion as the bug that broke our tests) with a bunch of now-failing xpcshell tests, showing the patch works as intended: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f27b05ce0e37
Comment on attachment 8808246 [details]
Bug 1310855 - Remove hasNode xpcshell.ini variable

https://reviewboard.mozilla.org/r/91088/#review90878
Attachment #8808246 - Flags: review?(mcmanus) → review+
Pushed by hurley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/143f26b923d0
Remove hasNode xpcshell.ini variable r=mcmanus
Backed out in https://hg.mozilla.org/integration/autoland/rev/664d575de979 for being a week too early - we'll stop testing WinXP on the trunk after 52 merges to aurora next week, but this week you still have to pass, and that fails on WinXP, https://treeherder.mozilla.org/logviewer.html#?job_id=6246437&repo=autoland
*sigh* love how WinXP tests didn't run on my try push, apparently I missed some magic incantation?

ni?ing myself so I remember to re-land this when XP isn't such a pain.
Flags: needinfo?(hurley)
Pushed by hurley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/851a50989291
Remove hasNode xpcshell.ini variable r=mcmanus
Re-landed, as we do appear to not be testing anything on xp any more (as promised).
Flags: needinfo?(hurley)
https://hg.mozilla.org/mozilla-central/rev/851a50989291
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.