Add an option to switch into reader mode automatically

RESOLVED WONTFIX

Status

()

Toolkit
Reader Mode
P3
enhancement
RESOLVED WONTFIX
2 years ago
26 days ago

People

(Reporter: Scott Bonds, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; OpenBSD amd64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160725224408




Expected results:

Reader mode is fantastic. I would like it to be activated automatically on any page I read that supports it, so I don't have to notice and click the reader mode icon. I tend to forget about reader mode and I end up zooming in on the page and such instead of using this great feature.
(Reporter)

Updated

2 years ago
Severity: normal → enhancement

Updated

2 years ago
Component: Untriaged → Reader Mode
Product: Firefox → Toolkit

Updated

a year ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Updated

10 months ago
Duplicate of this bug: 1404528

Comment 2

26 days ago
You can now do this with an add-on. I don't think we'll make this part of Firefox itself. There are too many issues with doing this. Among others:
- any time reader mode thinks it'll work, it'll apply itself, which won't be desired in a non-trivial number of cases
- it'd add to the loading time of websites
- it'd be tricky to keep "correct" back/forward navigation and also allow for people to exit reader mode if reader mode "worked" in that it produced valid output, but didn't work for the user (in that they couldn't use the website with reader mode applied).
- it'd be a significant maintenance concern, especially if we added UI for such an option.

I expect that add-ons will figure out what's a good way to do this. Perhaps a per-site permanent opt-in (e.g. "Always render content on bbc.co.uk in reader mode" or whatever). But I still suspect that the first point above would be a significant problem with doing this...
Status: NEW → RESOLVED
Last Resolved: 26 days ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

26 days ago
Got it. Thanks for closing the loop on the ticket!
You need to log in before you can comment on or make changes to this bug.