Losing GA info on new /confirm page

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jdavis, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Post the update on /confirm to show the email preference center (Bug 1297399) - we're now losing GA data for traffic for confirm.


User story:
As an email program manager, I need the ability to track GA utm parameters from the /confirm link, so that I can easily see the conversion results from the tests I'm running on optimizing the confirmation email messages.

(This data is in Salesforce, but can only be pulled at the day level - which makes it hard to track changes and efficacy if we make changes mid-day).

CCing Ben to add more context.

Timing: this sprint/early next if possible.

Comment 1

2 years ago
You can see the issue here (import this custom report into your analytics view for moz.org (production): 

https://analytics.google.com/analytics/web/template?uid=SUAvrIo3T7ehS3CQnHScFA

This page shows campaigns captured by the newsletter/confirm page. 

Traffic to the page stops almost entirely on Oct. 6. 

If we add utm parameters to the confirm link in SFMC (formerly known as ExactTarget) those parameters aren't captured on the confirm page. They are likely not captured as part of the re-direct, although I could be wrong. 

The reason to capture utm: if we are trying to optimize confirm emails, SFMC only lets users view click stats by full day. We need to know how many clicks from the email came from which version of the email to speed up testing and optimization of this important message. 

Thanks.
This is because the confirm page and email preference center are now one and the same. When a user hits "confirm" they are confirmed and redirected to "existing". We just have to detect UTM params and tack them onto the redirect. The GA info will then show up for the "existing" page, but with an extra parameter "confirm=1". Hopefully that will allow you to segment in GA. If not we can rework how these urls work.
Peter - wondering if you can confirm whether the proposed solution will work. Please see Paul's comment 2 about the possibility of segmenting URLs in GA.
Flags: needinfo?(pgerman)

Comment 4

2 years ago
Hi Guys,

It looks like the UX changed and that is reflected by what we're seeing in GA. The way that we look at form completions in GA for the /existing/ page is with Goal 19.

https://pageshot.net/Zd9gQXJJHNhHzye7/analytics.google.com

@pmac - Assuming the campaign (UTM) parameters are passed through, this would show conversions by traffic source
@Jess & Ben, does that meet your need?

Thanks,

PG
Flags: needinfo?(pmac)
Flags: needinfo?(jdavis)
Flags: needinfo?(bniolet)

Comment 5

2 years ago
Peter, this should be just fine and dandy if we're able to pass through UTMs.
Flags: needinfo?(bniolet)
Above PR should do it. We should check again after it lands.
Flags: needinfo?(pmac)

Comment 8

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/4b7fe2681eafec48629138f640f5ebe0a6b5a815
Fix bug 1312027: Include confirm query params in success redirect

https://github.com/mozilla/bedrock/commit/3c7ee0f68669d215ebefd3c8a5919ff3ced4325a
Merge pull request #4446 from pmac/include-query-params-confirm-redirect-1312027

Fix bug 1312027: Include confirm query params in success redirect

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

2 years ago
bniolet - can you check to see if this is fixed once it goes live?


Thanks pmac and pgerman!
Flags: needinfo?(pgerman)
Flags: needinfo?(jdavis)
Flags: needinfo?(bniolet)

Comment 10

2 years ago
I can confirm. It's working great!!

https://analytics.google.com/analytics/web/template?uid=uDzJyrPbRwGXkYwaHIXilQ
Flags: needinfo?(bniolet)
You need to log in before you can comment on or make changes to this bug.