With async plugin painting Flash video on TVA website fails to paint / paints black

RESOLVED FIXED

Status

()

Core
Plug-ins
--
major
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: infoplus007, Unassigned)

Tracking

({regression})

49 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx, STR in comment #0, URL)

(Reporter)

Description

a year ago
1 -Go to this URL: http://www.tvanouvelles.ca/2016/10/23/le-photo-blocker-spray-bel-et-bien-interdit-confirme-la-sq

2- The  video start and you hear the sound but the image stay black.

Screenshot: http://i.imgur.com/ZqXoUzo.png

Tested with a brand new profile under Win7/64

Work Fine in Chrome.

N.B.:  TVS is the biggest private network channel in Quebec.

Comment 1

a year ago
Set about:config > dom.ipc.plugins.asyncdrawing.enabled=false as workaround.
Blocks: 1229961
Component: Untriaged → Plug-ins
Keywords: regression
Product: Firefox → Core
Build ID 	20161019084923
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

The issue is reproducible on the latest Firefox release (49.0.2) but not on the previous one (48.0.2) on the following:

OS:        Windows 10
Processor: AMD FX(tm)-8320 Eight-Core Processor(8 CPUs), ~3.5GHz
Memory:    16.0 GB
Card name: NVIDIA GeForce 210 

OS:        Windows 10
CPU:       Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz (4 CPUs), ~3.2GHz
RAM:       16.0 GB
Graphics:  Intel(R) HD Graphics 530

OS:        Window 8.1
Processor: AMD FX(tm)-8320 Eight-Core Processor(8 CPUs), ~3.5GHz
Memory:    16.0 GB
Card name: AMD 760G

It is not reproducible on:

OS:        Mac OS 10.11
Processor: 2,7 GHz Intel Core i5
Memory:    8.0 GB
Card name: Intel Iris Graphics 6100 1536 MB
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

a year ago
Whiteboard: gfx
Request for test with e10s disabled - yes it is reproducible. black for most part, I do see spinner and picture briefly before it blacks out again
Windows 10 Home
Intel Core i3-4005 CPU @ 1.70GHz
8GB
64 Bit OS / 32bit Firefox
Intel HD Graphics
Adobe Flash 23.0.0.185
Multi process disabled
It may help to have the about:support graphics section for the systems that show (and don't show) the problem.
Windows 10 Home
Intel Core i3-4005 CPU @ 1.70GHz
8GB
64 Bit OS / 32bit Firefox
Intel HD Graphics
Adobe Flash 23.0.0.185
Multi process disabled

Graphics
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	none
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	Yes; Using D3D11 API
Direct2D	true
DirectWrite	true (10.0.10586.0)
GPU #1
Active	Yes
Description	Intel(R) HD Graphics Family
Vendor ID	0x8086
Device ID	0x0a16
Driver Version	10.18.15.4274
Driver Date	8-13-2015
Drivers	igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
Subsys ID	19dd1043
RAM	Unknown
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
Decision Log
D3D9_COMPOSITING	
disabled by default: Disabled by default

Updated

a year ago
Summary: With Firefox 49.0.2 under Windows 7/64 Flash Video on TVA website stay black → With async plugin painting Flash video on TVA website fails to paint / paints black

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1312242
Whiteboard: gfx → gfx, STR in comment #0

Updated

a year ago
Resolution: DUPLICATE → FIXED
You need to log in before you can comment on or make changes to this bug.