Remove CSS pref "layout.css.variables.enabled"

RESOLVED FIXED in Firefox 55

Status

()

defect
P3
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: xidorn, Assigned: TYLin)

Tracking

({dev-doc-complete})

Trunk
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 wontfix, firefox55 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
CSS Variables has been enabled since Firefox 31. We should remove this pref.

Even if we do not remove it, it would not control CSS Variables in stylo.
Priority: -- → P3
Mass wontfix for bugs affecting firefox 52.
Comment hidden (mozreview-request)
Reporter

Comment 4

2 years ago
mozreview-review
Comment on attachment 8855594 [details]
Bug 1312328 - Remove CSS variables preference "layout.css.variables.enabled".

https://reviewboard.mozilla.org/r/127448/#review130164

Looks good, thanks.
Attachment #8855594 - Flags: review?(xidorn+moz) → review+

Comment 5

2 years ago
Pushed by tlin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07435005e74a
Remove CSS variables preference "layout.css.variables.enabled". r=xidorn

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/07435005e74a
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Duplicate of this bug: 1293589
I've added a note to the relevant browser compat info about this
https://developer.mozilla.org/en-US/docs/Web/CSS/Using_CSS_variables#Browser_compatibility
https://developer.mozilla.org/en-US/docs/Web/CSS/var#Browser_compatibility

I've also added a note to the Fx55 rel notes:
https://developer.mozilla.org/en-US/Firefox/Releases/55#CSS

Let me know if you think that covers it, or if anything else is needed. thanks!
Assignee

Comment 10

2 years ago
Chris, the documentation changes look good to me. Thanks.
You need to log in before you can comment on or make changes to this bug.