`firefox --preferences` no longer works (ReferenceError: sa is not defined nsBrowserContentHandler.js)

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

Trunk
Firefox 52
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
This is a regression from bug 1311223, I happened to spot whilst looking at eslint output to enable some more rules.

STR:

1) Start firefox with `firefox --preferences`

Expected Results:

- Opens Firefox with about:preferences showing.

Actual Results:

- Opens Firefox with the normal homepage. In the console it shows "ReferenceError: sa is not defined  nsBrowserContentHandler.js:234:3"
(Assignee)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8804222 [details]
Bug 1312716 - '-preferences' on the command line no longer works due to an undefined variable.

https://reviewboard.mozilla.org/r/88312/#review87316

::: browser/components/nsBrowserContentHandler.js:5
(Diff revision 1)
>  /* This Source Code Form is subject to the terms of the Mozilla Public
>   * License, v. 2.0. If a copy of the MPL was not distributed with this
>   * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
>  
> +/* eslint no-undef:2 */

Note: bug 1311312 is enabling no-undef globally.

We can't put no-undef in the .eslintrc as the rest of the directory isn't ready for that, but this file is clean after this change, so lets keep it that way.
Comment on attachment 8804222 [details]
Bug 1312716 - '-preferences' on the command line no longer works due to an undefined variable.

https://reviewboard.mozilla.org/r/88312/#review87346
Attachment #8804222 - Flags: review?(jaws) → review+

Comment 4

2 years ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/301d2126dd45
'-preferences' on the command line no longer works due to an undefined variable. r=jaws

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/301d2126dd45
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52

Updated

2 years ago
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.