Closed Bug 1312778 Opened 3 years ago Closed 3 years ago

High volume spike in Fx52 for FX_REFRESH_DRIVER_SYNC_SCROLL_FRAME_DELAY_MS

Categories

(Toolkit :: Telemetry, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: gfritzsche, Assigned: chutten|PTO)

References

(Blocks 1 open bug)

Details

(Whiteboard: [measurement:client])

Attachments

(1 file)

The evolution for FX_REFRESH_DRIVER_SYNC_SCROLL_FRAME_DELAY_MS went way up with the Fx 52 of bug 1218576:
https://mzl.la/2eIdu0E
Summary: FX_REFRESH_DRIVER_SYNC_SCROLL_FRAME_DELAY_MS → High volume spike in Fx52 for FX_REFRESH_DRIVER_SYNC_SCROLL_FRAME_DELAY_MS
This may or may not be exactly bug 1304730. Investigating...
Comment on attachment 8805158 [details]
bug 1312778 - Ensure histogram recording is enabled before remote accumulation

https://reviewboard.mozilla.org/r/88662/#review88352

Good find.
We have test coverage for the parent side in test_nsITelemetry.js.
Can we add test coverage for the child too in test_ChildHistograms.js?
Priority: P2 → P1
Comment on attachment 8805158 [details]
bug 1312778 - Ensure histogram recording is enabled before remote accumulation

https://reviewboard.mozilla.org/r/88662/#review88814

Thanks.

::: toolkit/components/telemetry/tests/unit/test_ChildHistograms.js:31
(Diff revision 2)
> +  Telemetry.setHistogramRecordingEnabled("TELEMETRY_TEST_KEYED_COUNT", false);
> +  countKeyed.add("a");
> +  countKeyed.add("b");
> +  Telemetry.setHistogramRecordingEnabled("TELEMETRY_TEST_KEYED_COUNT", true);

Keyed histograms have slightly different code paths than non-keyed ones.
Lets add the same pattern for a non-keyed histogram to have good coverage.
Attachment #8805158 - Flags: review?(gfritzsche) → review+
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ee32f39572dd
Ensure histogram recording is enabled before remote accumulation r=gfritzsche
I had to back this out in https://hg.mozilla.org/integration/autoland/rev/d0f5bb427e0f2d7b0dbc68df53ccca5e151ff16d because it conflicted with bug 1304494, causing build bustage when that other bug got merged to autoland:

https://treeherder.mozilla.org/logviewer.html#?job_id=5917817&repo=autoland
Flags: needinfo?(chutten)
Via ryanvm on irc:
09:25:54 <RyanVM> oh I see
09:26:00 <RyanVM> dvander's patch changed the function signature
09:26:05 <RyanVM> chutten added a new call on autoland
09:26:49 <RyanVM> in the first hunk of https://hg.mozilla.org/integration/autoland/rev/ee32f39572dd76c9b6db98831d61b54c668147f5
09:27:04 <RyanVM> add a |, GeckoProcessType_Default| to that internal_GetHistogramByEnumId call
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/443c4ea33338
Ensure histogram recording is enabled before remote accumulation r=gfritzsche
https://hg.mozilla.org/mozilla-central/rev/443c4ea33338
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1304730
Flags: needinfo?(chutten)
Submission volumes for the probe have returned to pre-bug 1218576 levels https://mzl.la/2fQpQb2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.