Pressing Left/Right/Up/Down arrows on <Select> has issues

VERIFIED FIXED in Firefox 53

Status

()

defect
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: jwilliams, Assigned: enndeakin)

Tracking

(Blocks 1 bug, {regression})

52 Branch
mozilla53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 wontfix, firefox50 wontfix, firefox51+ wontfix, firefox52+ wontfix, firefox53 verified)

Details

()

Attachments

(1 attachment, 1 obsolete attachment)

STR:
1. Navigate to https://people.mozilla.org/~mnoorenberghe/w3c_notifications.htm
2. Click the Direction datalist
3. Navigate through the list by pressing the left/right/up/down arrows.

Actual:
E10s=True:
Pressing Left/Right arrows does nothing. Up/Down loops through the list.

E10s=False:
Pressing Left/Right arrows navigates Up/down through the list. Left/Right/Up/Down does not loop through the list. stops a position 0 and length-1

Affected OSes Windows and Ubuntu
No longer blocks: 1296638
Summary: Pressing Left/Right/Up/Down arrows on Non-login fields with data list has issues → Pressing Left/Right/Up/Down arrows on <Select> has issues
mozregression --good 2014-05-20 --bad 2014-05-21 

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9f34f73ebe&tocha
nge=9d8d16695f6a
Same reasoning as bug 1313130.
Assignee: nobody → enndeakin
Blocks: e10s-select
This is the system behavior:

Mac:  doesn't loop, left/right do nothing
Linux: loops, left/right do nothing
Windows, menus: loops, left/right do nothing
Windows, dropdowns: doesn't loop, left/right do nothing

Linux is correct currently.

Changes needed:

1. Mac should never loop for any menu or dropdown.
2. Windows should never loop for dropdowns only.
3. Windows dropdowns navigate when left/right is pressed.

The non-looping behaviour can be easily changed. I'm not sure if (3) is worth adding the extra complexity for; neither Chrome nor IE handle this either. Regardless it would be a low priority.
Status: NEW → ASSIGNED
Some tests need to be adjusted as they rely on wrapping occurring.
Attachment #8808996 - Attachment is obsolete: true
Attachment #8811232 - Flags: review?(ksteuber)
Comment on attachment 8811232 [details] [diff] [review]
Don't wrap when pressing cursor up/down in the right places for menus/menulists, also fix some tests

Review of attachment 8811232 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/tests/chrome/test_menulist_keynav.xul
@@ +265,5 @@
> +  list.selectedIndex = 3;
> +  list.menuBoxObject.activeChild = list.selectedItem;
> +  synthesizeKey("VK_DOWN", { });
> +  is(list.menuBoxObject.activeChild,
> +     document.getElementById(iswin || ismac ? "b4" : "b1"), "cursor up wrap while open");

It looks like the text on this line should say "cursor down wrap while open".
Attachment #8811232 - Flags: review?(ksteuber) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ed7a34ea7ab5e1f9febafca8133c9959e151db5
Bug 1313131, don't wrap when using cursor navigation in menus onr dropdowns on Mac, or dropdowns on Windows, r=ksteuber
https://hg.mozilla.org/integration/mozilla-inbound/rev/98d67bafe40ad311ecb0c6b07358840ae86a2e0c
Bug 1313131, don't wrap when using cursor navigation in menus onr dropdowns on Mac, or dropdowns on Windows, r=ksteuber
https://hg.mozilla.org/mozilla-central/rev/98d67bafe40a
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
I can verify that it does not loop anymore. But, when e10s is enabled Left & Right arrows do nothing and with e10's disabled Left & Right go Up & Down. Only half of what was reported has been fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
As indicated in comment 3, I don't think the left/right behaviour is worth adding the extra complexity for, and it only applies to dropdowns on Windows. But please file a separate bug for it so it is easier to track.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Flags: needinfo?(jwilliams)
Neil, want to uplift this fix to aurora and possibly beta?
Flags: needinfo?(enndeakin)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #15)
> Neil, want to uplift this fix to aurora and possibly beta?

I don't see any reason to.
Flags: needinfo?(enndeakin)
Justin, did the follow-up bug requested in comment 13 ever get filed?
Sorry for the late reply. I was not getting the ni emails for this until last night. I just filed the bug. it is bug 1321810
Flags: needinfo?(jwilliams)
QA Whiteboard: [good first verify]
I have reproduced this bug with Firefox nightly 52.0a1(build id:20161026030210)on
windows 7(64 bit)

I have verified this bug as fixed with Firefox beta 53.0b9 (build id:20170403072723)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

 [bugday-20170405]
Tanks Kazi Nuzhat Tasnem for testing.

I also confirm that the issue is no longer reproducible on Firefox 53.0b9, under Mac OS X 10.12.2, or under Ubuntu 16.04x64.

Note that on Ubuntu, Up/Down loops through the list, which is expected according to Comment 3.

I'm marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.