If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Signature with trailing white spaces in bug 1312064 does not link to correct search result

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
11 months ago
9 months ago

People

(Reporter: kanru, Assigned: adrian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 months ago
In bug 1312064 the crash signature [@ IPCError-browser | PBrowser::Msg_PDocAccessibleConstructor Processing error: message was deserialized, but the handler ] does not link to the correct link

https://crash-stats.mozilla.com/signature/?signature=IPCError-browser%20|%20PBrowser%3A%3AMsg_PDocAccessibleConstructor%20Processing%20error%3A%20message%20was%20deserialized%2C%20but%20the%20handler%20#aggregations

It does not show on Bugs field on crash-stats either.
(Reporter)

Comment 1

11 months ago
ping?
Flags: needinfo?(peterbe)
I honestly don't understand what this bug is about. Sorry. Can you try to explain what's what?
Flags: needinfo?(peterbe)
(Reporter)

Comment 3

11 months ago
(In reply to Peter Bengtsson [:peterbe] from comment #2)
> I honestly don't understand what this bug is about. Sorry. Can you try to
> explain what's what?

The signature [@ IPCError-browser | PBrowser::Msg_PDocAccessibleConstructor Processing error: message was deserialized, but the handler ] is #2 for the 20161107030203 build in https://crash-stats.mozilla.com/search/?build_id=20161107030203&release_channel=nightly&product=Firefox&platform=Windows&date=%3E%3D2016-11-07T00%3A00%3A00.000Z&date=%3C2016-11-09T14%3A01%3A00.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

It does not link to bug 1270916 although the bug has the signature in the Crash Signature field
(Assignee)

Comment 4

11 months ago
Peter, I believe that's an issue with our bugzilla cron job. Could it be caused by the trailing white space in that signature?
We've noticed something similar a while ago, ended up filing bug 1285998.
Regexps also don't work well for crash signatures, I don't remember the bug number.
In my case, I simply did something like o1=substring&f1=cf_crash_signature&v1=[@SIGNATURE]&o2=substring&f2=cf_crash_signature&v1=[@ SIGNATURE]&o3=substring&f3=cf_crash_signature&v3=[@SIGNATURE ]&o4=substring&f4=cf_crash_signature&v4=[@ SIGNATURE ].
(Assignee)

Comment 6

10 months ago
I believe the best solution to this problem would be to make sure there can be no white space at the end of a signature. It means that the signature will change, but we can easily reprocess the affected crash reports. And that would avoid weird bugs like this one in the future.
Assignee: nobody → adrian
(Assignee)

Comment 7

10 months ago
Created attachment 8813508 [details] [review]
Link to Github pull-request: https://github.com/mozilla/socorro/pull/3602
See Also: → bug 1320838

Comment 8

9 months ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/241d355150bf515af8118bf2aef2c30221c557f5
Fixes bug 1313283 - Strip signatures from leading or trailing white spaces. (#3602)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
(Assignee)

Updated

9 months ago
Duplicate of this bug: 1323210
(Assignee)

Comment 10

9 months ago
We'll probably want to reprocess a bunch of crashes with trailing white spaces once this lands on prod.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

9 months ago
I've ran this command on stage and prod: 

envconsul -prefix socorro/common -prefix socorro/crontabber python socorro/cron/crontabber_app.py -j bugzilla-associations -f --crontabber.class-BugzillaCronApp.days_into_past=30

We should be good with this.
Status: REOPENED → RESOLVED
Last Resolved: 9 months ago9 months ago
Resolution: --- → FIXED
Does it take time for the changes to propagate? For the link in comment 2 I still see an empty bug field for crash #2.
You need to log in before you can comment on or make changes to this bug.