Closed Bug 1314022 Opened 4 years ago Closed 4 years ago

mach test not finding any tests to run when trying to run a browser mochitest

Categories

(Firefox Build System :: Mach Core, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1313716

People

(Reporter: bsilverberg, Unassigned)

Details

After pulling the latest from mozilla-central today, when trying to run a browser mochitest via |mach test|, e.g., |./mach test browser/components/extensions/test/browser/browser_ext_sessions.js|, I am told that no tests are found to run. The message is "ERROR no tests to run using specified combination of filters: skip_if, run_if, fail_if, remove_imptest_failure_expectations, subsuite(name=)".

I have tried this against a debug build and an optimized build (both artifact builds) on OS X 10.11.6.

Is this a regression, or do I need a different config or command as of today in order to run browser mochitests?
In case this was somehow just an issue with artifact builds, I tested as well with a full build. I just did a full, debug build with the latest code from m-c and I am still seeing this issue. Unless this is somehow just affecting me, this seems like a pretty big deal.
Flags: needinfo?(ahalberstadt)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ahalberstadt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1313716
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.