Chatzilla broken in SeaMonkey 2.49 after bug 1312143

RESOLVED FIXED

Status

Other Applications
ChatZilla
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.93])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
Bug 1312143 removed some obsolete files from toolkit. Chatzilla is completly broken by it. It will not show any content in its window. I didn't test it with Firefox 52 but it should be the same there.
(Assignee)

Updated

2 years ago
See Also: → bug 1313288
(Assignee)

Comment 1

2 years ago
Created attachment 8806525 [details] [diff] [review]
1314457-copytoolkit.patch

Taking the easy way and just copying the obsolete parts. globalOverlay.xul did only pull globaloverlay.js in which is still there. Not copying this one. 

Setting version so that auto update works.

I don't have time right now to integrate the parts into the code. If this approach is ok I am happy to take the bug.
Attachment #8806525 - Flags: feedback?(rginda)
(Assignee)

Updated

2 years ago
Blocks: 1313304

Comment 2

2 years ago
Comment on attachment 8806525 [details] [diff] [review]
1314457-copytoolkit.patch

Review of attachment 8806525 [details] [diff] [review]:
-----------------------------------------------------------------

::: locales/en-US/chrome/chatzilla.properties
@@ +33,5 @@
>  #       localisations between versions easier.
>  #
>  ### End of notes ###
>  
> +locale.version = 0.9.93

You didn't add locale properties, so this shouldn't change

::: xul/content/chatzilla.xul
@@ +21,5 @@
>    orient="vertical" onload="onLoad();" onunload="onUnload();"
>    onclose="return onClose();" onmouseover="onMouseOver(event);"
>    persist="width height screenX screenY sizemode" windowtype="irc:chatzilla">
> +
> +  <script type="application/javascript" src="chrome://global/content/globalOverlay.js"/>

This should probably go in scripts.xul as well?

::: xul/content/static.js
@@ +3,5 @@
>   * This Source Code Form is subject to the terms of the Mozilla Public
>   * License, v. 2.0. If a copy of the MPL was not distributed with this
>   * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
>  
> +const __cz_version   = "0.9.93";

I mean, we should probably do another release anyway, but we should include some other stuff. Right now I don't think we should change this.

@@ +8,4 @@
>  const __cz_condition = "green";
>  const __cz_suffix    = "";
>  const __cz_guid      = "59c81df5-4b7a-477b-912d-4e0fdf64e5f2";
> +const __cz_locale    = "0.9.93";

This should definitely not change.
Attachment #8806525 - Flags: feedback?(rginda) → feedback+

Updated

2 years ago
Assignee: rginda → frgrahl
Status: NEW → ASSIGNED
(Assignee)

Comment 3

2 years ago
>> This should probably go in scripts.xul as well?

I will check it out tomorrow or Saturday at the latest and update the patch. 

>> Right now I don't think we should change this.

Will take it out if you wish but that would mean that existing SeaMonkey installations do not get updated until the user explicitly installs the new xpi.

I only updated the language pack xpi because I thought if the main version is updated it might look better if it matches the main xpi. But moot point if this isn't updated either :)
(Assignee)

Comment 4

2 years ago
Created attachment 8807270 [details] [diff] [review]
1314457-copytoolkit-V2.patch

Updated patch without version number increments. 

I checked it out in Firefox Nightly and it worked. I got a blank window in SeaMonkey but was unable to reproduce this in FF but I saw a similar report today in #developers. It seems if globalOverlay.js is already loaded you will not see an obvious error.
Attachment #8806525 - Attachment is obsolete: true
Attachment #8807270 - Flags: review?(gijskruitbosch+bugs)

Comment 5

2 years ago
Comment on attachment 8807270 [details] [diff] [review]
1314457-copytoolkit-V2.patch

Review of attachment 8807270 [details] [diff] [review]:
-----------------------------------------------------------------

r=me

We should file a followup to just wean ourselves off these copies, though.
Attachment #8807270 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 6

2 years ago
Hopefully fixed.

https://hg.mozilla.org/chatzilla/rev/a2a243f1713510e951c5df8063aa60a08408bfc6
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Whiteboard: [cz-0.9.93]
You need to log in before you can comment on or make changes to this bug.