Closed Bug 1314499 Opened 5 years ago Closed 4 years ago

Erratic behavior with Flash on Youtube

Categories

(Core :: Plug-ins, defect)

Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: glandium, Unassigned)

Details

There may be two bugs here, I don't know. Here is what I'm experiencing:

- On Youtube, I found some videos that don't work in the HTML5 player. They're unfortunately not visible outside Japan thanks to geography-based restrictions by Sony Music Japan. Anyways, an example of such a video is: https://www.youtube.com/watch?v=MqfiFhRlIAQ

- When the flash plugin is "Always activate", loading the url above leads to a black frame for the video (and no sound ; the plugin container process doesn't seem to even start). Disabling the flash plugin then reenabling it in about:addons, then reloading the url then makes the video work, using Flash.

- When the flash plugin is "Ask to activate", loading the url leads to, presumably, the CtP frame to show up briefly, before it's replaced with the HTML5 player, which then fails with "Your browser does not currently recognize any of the video formats available". There is a plugin icon in the notification area (if that its name) next to the url, where it can be allowed, after which the video plays in flash.

OS is Linux ; Flash plugin is version 11.2 r202, which is rather old, I think, but I only enabled it when Anthony Jones asked me to to check if the video worked with Flash. Plugincheck seems to think it's up-to-date.
Flags: needinfo?(blassey.bugs)
Heh, interestingly, I can't reproduce the black frame anymore :(
Hey Mike, did you have a question for me?
Flags: needinfo?(blassey.bugs)
Can you check today's nightly? a fix landed to help with some of these issues.
Blocks: 1229961
Flags: needinfo?(mh+mozilla)
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #2)
> Hey Mike, did you have a question for me?

Not specifically. Ajones told me to ni? you when filing the bug.

(In reply to Jim Mathies [:jimm] from comment #3)
> Can you check today's nightly? a fix landed to help with some of these
> issues.

The behavior for "Always activate" doesn't happen anymore, but then, I already couldn't reproduce it with the build that failed previously.

The behavior for "Ask to activate" is unchanged.
Flags: needinfo?(mh+mozilla)
Unrelated to async painting since this was reported on linux.
No longer blocks: 1229961
OS: Unspecified → Linux
We're not going to change the ask-to-activate behavior: youtube is detecting and falling back, perhaps-incorrectly, but also we're all killing Flash with fire so quickly that they are likely to fix this soon anyway.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.