[e10s] <select> dropdown list should handle Full/Text Zoom on Windows10, Text Zoom on Linux.

RESOLVED FIXED in Firefox 52

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
8 months ago
8 months ago

People

(Reporter: Alice0775 White, Assigned: Neil Deakin (not available until Aug 9), NeedInfo)

Tracking

(Blocks: 2 bugs, 4 keywords)

Trunk
mozilla52
Unspecified
All
multiprocess, pp, qawanted, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

(Whiteboard: [qawanted for Full/Text Zoom on Windows10])

Attachments

(5 attachments)

(Reporter)

Description

8 months ago
<select> dropdown list is not respect browser zoom level, So It is too hard to read/distinguish them.

Steps To Reproduce:
1. Open attached
2. Expand drop down
3. Zoom up

Actual Results:
Emoji font size is too small for me. So It is too hard to read/distinguish them.

Expected Results:
<select> dropdown list is not respect browser zoom level.
(Reporter)

Comment 1

8 months ago
Created attachment 8806921 [details]
select dropdown emoji.html (charset unicode)
It does respect the zoom level for me.

Do you mean that the shortcut doesn't work while the popup is open?
(Reporter)

Comment 3

8 months ago
Created attachment 8806934 [details]
screenshot when zoom up
(Reporter)

Comment 4

8 months ago
(In reply to Neil Deakin from comment #2)
> It does respect the zoom level for me.

See screenshot

> Do you mean that the shortcut doesn't work while the popup is open?

No.
(Reporter)

Comment 5

8 months ago
On windows10  : Both Full Zoom and Text Zoom does not work
On Ubuntu16.04: Full Zoom works as expected. However, Text Zoom does not work
(Reporter)

Updated

8 months ago
Keywords: pp
OS: Windows 10 → All
Looks like full zoom works for me on all platforms, but text zoom needs to be fixed.

Also, I don't get any images in the testcase; just the characters that appear in the source.
(Assignee)

Updated

8 months ago
Summary: [e10s] <select> dropdown list is not respect browser zoom level, So It is too hard to read it. → [e10s] <select> dropdown list should handle text only zoom
(Reporter)

Comment 7

8 months ago
(In reply to Neil Deakin from comment #6)
> Looks like full zoom works for me on all platforms, but text zoom needs to
> be fixed.
> 
> Also, I don't get any images in the testcase; just the characters that
> appear in the source.

No, 
The problem is not only Text Zoom but also Full zoom on windows10.

On Linux, The problem is Text Zoom only.
Summary: [e10s] <select> dropdown list should handle text only zoom → [e10s] <select> dropdown list should handle Full/Text Zoom on Windows10, Text Zoom on Linux.
(Reporter)

Updated

8 months ago
Keywords: qawanted
Whiteboard: [qawanted for Full/Text Zoom on Windows10]
(Reporter)

Comment 8

8 months ago
Created attachment 8807117 [details]
Textcase ordinary Latin text
(Reporter)

Comment 9

8 months ago
Created attachment 8807119 [details]
screenshot about Textcase ordinary Latin text
Created attachment 8807120 [details] [diff] [review]
Update using either full zoom or text zoom

This patch handles the full vs text zoom setting.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8621c19d073a
(Reporter)

Updated

8 months ago
Attachment #8806921 - Attachment description: select dropdown emoji.html → select dropdown emoji.html (charset unicode)
(Reporter)

Comment 12

8 months ago
(In reply to Neil Deakin from comment #11)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=8621c19d073a

On Ubuntu16.04: The try build fixed Text Zoom. So, Full Zoom and Text Zoom works as expected.

However,
On windows10  : It seems nothing changed from regular Nightly52.0a1. Both Full Zoom and Text Zoom *does not* work.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0662eda97663
(Reporter)

Comment 14

8 months ago
(In reply to Neil Deakin from comment #13)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=0662eda97663

Same results as before...

On Ubuntu16.04: The try build fixed Text Zoom. So, Full Zoom and Text Zoom works as expected.

On windows10  : It seems nothing changed from regular Nightly52.0a1. Both Full Zoom and Text Zoom *does not* work.
I see this patch working for on all platforms (Windows 7, Ubuntu, Mac).

This doesn't seem like something that would depend on the specific operating system version or settings.

Anyway, even so, this patch is better that what existed before, so I think we can use it for now.
(Assignee)

Updated

8 months ago
Attachment #8807120 - Flags: review?(felipc)
(Reporter)

Comment 16

8 months ago
BTW,
This is a regression for Full Zoom on Windows10.


Regression window:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=f03e2740d604d339ed553dad62a3fc54c317f8fa&tochange=83461556cda59e8bcd54f09b9263e3202ce01dc2

Regressed by: 83461556cda5	Mark Golbeck — Bug 1091592 - Improve style of select dropdowns, including adding more padding for touch-enabled devices. r=jaws



@Neil Deakin
I think that it need to enabling accessibility device such as IME or something.
Blocks: 1091592
Flags: needinfo?(markgolbeck08)
Keywords: regression
Could it be that the patch is using 'px' instead of a relative font-size unit such as 'rem'? Mark, please try changing your patch to use '.688rem', which is the equivalent of 11px for me on my Windows10 machine.
Attachment #8807120 - Flags: review?(felipc) → review+
I think the text zoom not working is one bug (fixed by the patch), and the Windows regression is another bug.
(Reporter)

Updated

8 months ago
Blocks: 1316722
(Reporter)

Comment 19

8 months ago
(In reply to Neil Deakin from comment #18)
> I think the text zoom not working is one bug (fixed by the patch), and the
> Windows regression is another bug.

Okay, I have filed Bug 1316722.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0baa46cbe531
https://treeherder.mozilla.org/#/jobs?repo=try&revision=31370d478861
https://hg.mozilla.org/integration/mozilla-inbound/rev/e976fd4936e3e686719230b04a7e57ba19888f17
Bug 1314802, handle text zoom for select popups, r=felipe

Comment 23

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e976fd4936e3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.