Can no longer build Firefox under Windows 10

RESOLVED DUPLICATE of bug 1314894

Status

Firefox Build System
General
--
blocker
RESOLVED DUPLICATE of bug 1314894
2 years ago
5 months ago

People

(Reporter: WG9s, Unassigned)

Tracking

({regression})

Trunk
All
Windows 10
regression

Firefox Tracking Flags

(firefox52 fixed)

Details

(Reporter)

Description

2 years ago
I can no longer build Firefox under windows 10.  Here is the log snippet of the failure.

 1:43.34 js\src>   File "c:/Users/wag/mozilla/mozilla2/build/moz.configure/old.c
onfigure", line 359, in old_configure
 1:43.34
 1:43.34 js\src>     code = compile(fh.read(), 'config.data', 'exec')
 1:43.34
 1:43.34 js\src>   File "config.data", line 277
 1:43.34
 1:43.34 js\src>     (''' top_srcdir ''', r''' c:\Users\wag\mozilla\mozilla2\js\
src/../.. '''),
 1:43.34
 1:43.34 js\src> SyntaxError: (unicode error) 'rawunicodeescape' codec can't decode bytes in position 3-4: truncated \uXXXX
 2:13.64 DEBUG: <truncated - see config.log for full output>

 2:13.64 DEBUG: char posix_fallocate();
 2:13.64 DEBUG:
 2:13.64 DEBUG: int main() {
 2:13.64 DEBUG:
 2:13.64 DEBUG: ; return 0; }
 2:13.64 ERROR: old-configure failed
 2:13.69 *** Fix above errors and then restart with\
 2:13.69                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build
"
 2:13.70 client.mk:375: recipe for target 'configure' failed
 2:13.70 mozmake.EXE: *** [configure] Error 1
(Reporter)

Comment 1

2 years ago
Hg Bisect identified:

$ hg bisect -g
The first bad revision is:
changeset:   320413:a801ef597f1f
user:        Mike Hommey <mh+mozilla@glandium.org>
date:        Thu Oct 27 13:40:42 2016 +0900
summary:     Bug 1313306 - Relax the rules for --help dependencies. r=chmanchester
Blocks: 1313306
Keywords: regression
(Reporter)

Updated

2 years ago
Component: JavaScript Engine → Build Config
(Reporter)

Comment 2

2 years ago
I could try to verify via backout, but to many patches for me to waste my time doing that.  please just fix this.
Flags: needinfo?(mh+mozilla)
Backing out a801ef597f1f didn't fix the build for me.
(Reporter)

Comment 4

2 years ago
(In reply to Chris Pearce (:cpearce) from comment #3)
> Backing out a801ef597f1f didn't fix the build for me.

Oh but I am glad someone else is experiencing the issue.  I had thought maybe it was specific to my build configuration.
My hg bisect says:

The first bad revision is:
changeset:   360834:0ac9e88ff47b
user:        Mike Hommey <mh+mozilla@glandium.org>
date:        Wed Oct 26 16:42:06 2016 +0900
summary:     Bug 1313306 - Allow @depends(when=something) without additional dependencies. r=chmanchester

...but backing that out results in:

 0:00.66 c:\mozilla-build\mozmake\mozmake.EXE -f client.mk -s configure
 0:03.07 cd c:/Users/cpearce/src/mozilla/purple/obj-i686-pc-mingw32
 0:03.09 c:/Users/cpearce/src/mozilla/purple/configure
 0:03.33 Traceback (most recent call last):
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/configure.py", line 107, in <module>
 0:03.33     sys.exit(main(sys.argv))
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/configure.py", line 26, in main
 0:03.33     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 330, in run
 0:03.33     self.include_file(path)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 321, in include_file
 0:03.33     exec_(code, self)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\util.py", line 59, in exec_
 0:03.33     exec(object, globals, locals)
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/moz.configure", line 7, in <module>
 0:03.33     include('build/moz.configure/init.configure')
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 619, in include_impl
 0:03.33     self.include_file(what)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 321, in include_file
 0:03.33     exec_(code, self)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\util.py", line 59, in exec_
 0:03.33     exec(object, globals, locals)
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/build/moz.configure/init.configure", line 7, in <module>
 0:03.33     include('util.configure')
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 619, in include_impl
 0:03.33     self.include_file(what)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 321, in include_file
 0:03.33     exec_(code, self)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\util.py", line 59, in exec_
 0:03.33     exec(object, globals, locals)
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/build/moz.configure/util.configure", line 348, in <module>
 0:03.33     always = dependable(True)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 660, in wrapper
 0:03.33     ret = template(*args, **kwargs)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 924, in wrapped
 0:03.33     return new_func(*args, **kwargs)
 0:03.33   File "c:/Users/cpearce/src/mozilla/purple/build/moz.configure/util.configure", line 345, in dependable
 0:03.33     return depends(when=True)(lambda: obj)
 0:03.33   File "c:\Users\cpearce\src\mozilla\purple\python\mozbuild\mozbuild\configure\__init__.py", line 575, in depends_impl
 0:03.33     raise ConfigureError('@depends needs at least one argument')
 0:03.33 mozbuild.configure.ConfigureError: @depends needs at least one argument
 0:03.34 *** Fix above errors and then restart with\
 0:03.34                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build"
 0:03.35 client.mk:375: recipe for target 'configure' failed
 0:03.35 mozmake.EXE: *** [configure] Error 1
(Reporter)

Comment 6

2 years ago
I am trying a build including the patch from bug 1314894.   This looks promising.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314894
Flags: needinfo?(mh+mozilla)
marking fixed in 52 per bug 1314894
status-firefox52: affected → fixed

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.