No longer use direct2d 1.1 for AzureCanvasBackend and AzureContentBackend, but use Skia in about:support

RESOLVED DUPLICATE of bug 1314803

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 1314803
3 years ago
3 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

(4 keywords)

52 Branch
x86
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 unaffected, firefox52- fix-optional)

Details

Attachments

(2 attachments)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/c44c01dfd264370c1558b747525d220a9a89b51c
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 ID:20161106030203


STR
1. Open about:support


Actual Results:
  AzureCanvasAccelerated        0
  AzureCanvasBackend            skia
  AzureContentBackend           skia
  AzureFallbackCanvasBackend    cairo

Expected Results:
  AzureCanvasAccelerated        0
  AzureCanvasBackend            direct2d 1.1
  AzureContentBackend           direct2d 1.1
  AzureFallbackCanvasBackend    cairo


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c04f84afb1bd6b3ea372164012735de6c8f2d582&tochange=b4ade2b0841c5825968f34752d86ee09507a0a9f


Triggered by:
b4ade2b0841c	David Anderson — Enable the GPU process for Nightly Windows users. (bug 1314133, r=milan)
[Tracking Requested - why for this release]: Regression

and blurry text in some places like select dropdown menus etc. probably due to Skia usage and its not fixed very long time standing bugs about blurry fonts in text...
Severity: normal → major
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(dvander)
Keywords: regression
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #2)
> [Tracking Requested - why for this release]: Regression
> 
> and blurry text in some places like select dropdown menus etc. probably due
> to Skia usage and its not fixed very long time standing bugs about blurry
> fonts in text...

If you're seeing something that has existed for a very long time, it sounds like a separate bug.
Flags: needinfo?(dvander)
This looks like bug 1314803. The right values are being chosen in the content process (you can see Direct2D is enabled), but about:support only shows the UI process. We're going to have to report on a per-window basis, or report content and UI separately.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314803
(In reply to David Anderson [:dvander] from comment #3)
> (In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #2)
> > [Tracking Requested - why for this release]: Regression
> > 
> > and blurry text in some places like select dropdown menus etc. probably due
> > to Skia usage and its not fixed very long time standing bugs about blurry
> > fonts in text...
> 
> If you're seeing something that has existed for a very long time, it sounds
> like a separate bug.

Kinda, but this reveals it now completely, due to Skia rendering, not Direct2D,
but I will diagnose it more deeply and report back maybe in new bug.
Tracking 52- for this dupe.
We have to change the status flag to something that isn't "affected" for it to fall off the engineering/relman triage.
You need to log in before you can comment on or make changes to this bug.