The default bug view has changed. See this FAQ.

Enable the GPU process in nightly, on Windows

RESOLVED FIXED in Firefox 52

Status

()

Core
Graphics
RESOLVED FIXED
5 months ago
6 days ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

(Depends on: 3 bugs)

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 months ago
This will just be for Nightly, and only for Windows users.
(Assignee)

Comment 1

5 months ago
Created attachment 8806109 [details] [diff] [review]
patch

Enables out-of-process compositing for Nightly users that meet the following conditions:
 (1) Use Windows 7 with the Platform Update, or higher, and
 (2) Are able to use Direct3D 11 compositing.

Intent is not to check this in until blocking bugs are fixed.
Attachment #8806109 - Flags: review?(milan)
Comment on attachment 8806109 [details] [diff] [review]
patch

Review of attachment 8806109 [details] [diff] [review]:
-----------------------------------------------------------------

::: modules/libpref/init/all.js
@@ +4533,5 @@
>  // Preference that when switched at runtime will run a series of benchmarks
>  // and output the result to stderr.
>  pref("layers.bench.enabled", false);
>  
> +#ifdef XP_WIN && defined(NIGHTLY_BUILD)

Drive-by: this syntax seems wrong. shouldn't be it #if defined(XP_WIN) && defined(NIGHTLY_BUILD) ?
(Assignee)

Comment 3

5 months ago
It looks weird, but I literally copied it from elsewhere in the file. I can change it though.
Might be broken in the other place too, who knows. Or maybe our in-house preprocessor accidentally does the right thing on this syntax?
Depends on: 1314193
(Assignee)

Comment 5

5 months ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> Might be broken in the other place too, who knows. Or maybe our in-house
> preprocessor accidentally does the right thing on this syntax?

It parses fine but seems to evaluate to #if 0. Hah. Thanks, I'll put a new patch up.
Comment on attachment 8806109 [details] [diff] [review]
patch

Review of attachment 8806109 [details] [diff] [review]:
-----------------------------------------------------------------

\o/ Kats' comment non-withstanding.
Attachment #8806109 - Flags: review?(milan) → review+

Comment 7

5 months ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/59d33178b0cd
Enable out-of-process D3D11 compositing for Nightly Windows users. (bug 1314133, r=milan)
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/28ed60ea7e1117144e10ed931df1dfc9437dacbf for https://treeherder.mozilla.org/logviewer.html#?job_id=38536570&repo=mozilla-inbound
(Assignee)

Comment 9

5 months ago
I can reproduce this, investigating.

Comment 10

5 months ago
When I manually add "layers.gpu-process.dev.enabled = true" I get this in about:support graphics section:

Hardware H264 Decoding	Yes; Failed to create D3D11 device for decoder; Using D3D9 API
(In reply to Gary [:streetwolf] from comment #10)
> When I manually add "layers.gpu-process.dev.enabled = true" I get this in
> about:support graphics section:
> 
> Hardware H264 Decoding	Yes; Failed to create D3D11 device for decoder; Using
> D3D9 API

Can you please attach your full about:support from when this happens?

Comment 12

5 months ago
Created attachment 8806898 [details]
Support.zip

The zip files contains:

support_false.txt = about:support with "layers.gpu-process.dev.enabled = false"
support_true.txt = about:support with "layers.gpu-process.dev.enabled = true"
(In reply to Gary [:streetwolf] from comment #12)
> Created attachment 8806898 [details]
> Support.zip
> 
> The zip files contains:
> 
> support_false.txt = about:support with "layers.gpu-process.dev.enabled =
> false"
> support_true.txt = about:support with "layers.gpu-process.dev.enabled = true"

Thanks!

Looks like this is a mainly a reporting problem, you should still be getting D3D11 DXVA for your videos.

I've filed bug 1314803 and bug 1314804 to track fixing this.
(Assignee)

Updated

5 months ago
Depends on: 1314816
Blocks: 1315141

Comment 14

5 months ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b4ade2b0841c
Enable the GPU process for Nightly Windows users. (bug 1314133, r=milan)

Comment 15

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b4ade2b0841c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52

Updated

5 months ago
Depends on: 1315540
Depends on: 1315568

Updated

5 months ago
Depends on: 1315699

Updated

5 months ago
Depends on: 1315715
Depends on: 1316062
(Assignee)

Updated

5 months ago
Blocks: 1316279
Although I have no idea why, and I personally cannot reproduce it, there are reports from Japanese people that this causes issue with printing.
Depends on: 1318845
Depends on: 1322897
Depends on: 1301658

Updated

3 months ago
Depends on: 1326915
Depends on: 1347370
You need to log in before you can comment on or make changes to this bug.