If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The site http://patrickhlauke.github.io/touch/pen-tracker/ does not work as intended with stylus

RESOLVED WORKSFORME

Status

()

Core
DOM: Events
P3
normal
RESOLVED WORKSFORME
11 months ago
9 months ago

People

(Reporter: asimonca, Assigned: stone)

Tracking

(Blocks: 1 bug)

52 Branch
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 affected)

Details

(URL)

(Reporter)

Description

11 months ago
[Affected versions]:
- Firefox Nightly 52.0a1

[Affected platforms]:
- Windows 10 x64

[Steps to reproduce]:
Make sure that the build has e10s enabled and the pref "browser.tabs.remote.force-enable" set to "true".
1. Go to about:config and set the "dom.w3c_pointer_events.enabled" preff to "true"
2. Go to http://patrickhlauke.github.io/touch/pen-tracker/ 
3. Drag the grid with a stylus.


[Expected result]:
- The grid can be moved and oriented.

[Actual result]:
- The grid can't be moved due to certain pen attributes that are not yet implemented in Pointer Events

[Regression range]:
- This is not a regression since the feature is new.

[Additional notes]:
- This issue is not reproducible by mouse or touch, only by stylus and only with Pointer Events preffed on.
You saw this, right, Stone and Ben?
Flags: needinfo?(sshih)
Flags: needinfo?(bhsu)
(Assignee)

Updated

10 months ago
Assignee: nobody → sshih
Flags: needinfo?(sshih)

Comment 2

10 months ago
Hi Andrew and sorry for missing this.

Though Stone has taken this issue, I'd to share my previous experience. The title of the page said that I need the pressure and tilt of a stylus, but the two are not correctly function at this moment. For the pressure part, since the current implementation is based on WM_MOUSE messages, and thus the pressure is always the default value. As to the the tilt part, IIRC, we use WidgetMouseEvent to communicate between the chrome process and the content process, while tilts are serialized in WidgetPointerEvent, and thus the information is lost when passing the IPC channel[0].

Since I don't have a device now, I am not sure whether this information helps... However, if we are luck enough, we can solve two filed bugs for the pressure and tilts :)

[0] http://searchfox.org/mozilla-central/source/widget/nsGUIEventIPC.h#221-258
[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1031362
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=1299197
Flags: needinfo?(bhsu)
Thanks for the info, Ben, and thanks for taking this, Stone! I just wanted to make sure you'd seen it :)
(Assignee)

Updated

10 months ago
Depends on: 1031362, 1299197
Stone, I notice the blockers of this bug are resolved, so wondering shall we close this bug as well?
Flags: needinfo?(sshih)
(Assignee)

Comment 5

9 months ago
Yes. Verified it with changeset 327544:6f63f95e28ff and it's resolved.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(sshih)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.