Attempting to load tab with video causes content tab spinner to be displayed and nothing else - GPU process & Media GPU Process Decoding interaction

RESOLVED FIXED in Firefox 53

Status

()

P3
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sciguyryan, Assigned: mattwoodrow)

Tracking

({regression})

52 Branch
mozilla53
x86_64
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox-esr45 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52 disabled, firefox53 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8808217 [details]
about:support information

This issue appears to be related to the enabling of the content GPU process.

Attempting to load a page with a video (noted originally on Youtube) causes the page to load and render to a point, then revert a white tab with nothing but the tab spinner present. Attempting to reload the page does not achieve anything and this issue appears to be completely repeatable.

Disabling the GPU process via layers.gpu-process.dev.enabled and restarting the browser appears to completely resolve the issue.

I have attached the contents of the about:support tab and a screenshot (not that there is much to show!) as separate attachments on this bug.

If I can provide any further information please let me know. Given the nature of the issue I am unsure what additional information would be useful here.
(Reporter)

Comment 1

2 years ago
Created attachment 8808218 [details]
Tab Spinner on Blank Tab
(Reporter)

Comment 2

2 years ago
After doing a little more research it seems to be an interaction between media.gpu-process-decoder being enabled and layers.gpu-process.dev.enabled being enabled.

As such I will leave this to someone else to figure out which component it should be filed against. Disabling either of these resolves the issue - enabling both causes it to reoccur.
(Reporter)

Updated

2 years ago
Summary: Attempting to load tab with video causes content tab spinner to be displayed and nothing else → IntAttempting to load tab with video causes content tab spinner to be displayed and nothing else - GPU process & Media GPU Process Decoding interaction
(Reporter)

Updated

2 years ago
Summary: IntAttempting to load tab with video causes content tab spinner to be displayed and nothing else - GPU process & Media GPU Process Decoding interaction → Attempting to load tab with video causes content tab spinner to be displayed and nothing else - GPU process & Media GPU Process Decoding interaction
No immediate ideas yet from me - Ryan, did you enable the media.gpu-process-decoder pref by hand?
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 4

2 years ago
(In reply to David Anderson [:dvander] from comment #3)
> No immediate ideas yet from me - Ryan, did you enable the
> media.gpu-process-decoder pref by hand?

Yes, I did enable it by hand for testing a while back.
Blocks: 1315141
Severity: critical → major
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox-esr45: --- → unaffected
Keywords: regression
Version: Trunk → 52 Branch
Blocks: 1307578
Priority: -- → P3
Whiteboard: [gfx-noted]
status-firefox52: affected → disabled
status-firefox53: --- → affected
(Reporter)

Comment 5

2 years ago
This still appears to be an issue in the latest nightly - I have just retested it this morning.

Do we have any further information regarding what is going on here?
(Reporter)

Comment 6

2 years ago
This appears to have been resolved by the patch landed in bug 1318083.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Updated

2 years ago
Flags: needinfo?(matt.woodrow)
Assignee: nobody → matt.woodrow
status-firefox53: affected → fixed
Depends on: 1318083
See Also: bug 1318083
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.